Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#2604 closed enhancement (duplicate)

Record circuit build timeouts

Reported by: karsten Owned by:
Priority: normal Milestone:
Component: Metrics Data Processor Version:
Keywords: TorPerfIteration20110305 Cc:
Actual Points: Parent ID:
Points: 0

Description

Torperf should record circuit build timeouts, in addition to circuit build times (#2551). I think we came up with two subtasks:

  1. Learn about the current circuit build timeout and when it changes. Mike says we can add an event handler callback for this.
  2. Output this data in some format for subsequent analysis. I think we shouldn't try to squeeze circuit build timeouts into one of the current data formats, but should instead write them to a new file. We need to rethink the data formats anyway, but that's not on the list for the current Torperf sprint.

Mike, want to have a look at this task? It seems you're the person who knows best what needs to be modified for the first subtask.

Child Tickets

Change History (4)

comment:1 Changed 3 years ago by karsten

  • Owner karsten deleted
  • Status changed from new to assigned

comment:2 Changed 3 years ago by karsten

  • Keywords TorPerfIteration20110305 added

comment:3 Changed 3 years ago by karsten

  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #2590. Closing.

comment:4 Changed 3 years ago by dchasteen

  • Points set to 0

Duplicate. Set to 0 points.

Note: See TracTickets for help on using tickets.