Opened 19 months ago

Closed 18 months ago

Last modified 14 months ago

#26041 closed project (duplicate)

Set Default version to 3 for new onion; V2 onion can be cracked easily

Reported by: cypherpunks Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Currently, the user should add 'Version 3' to torrc to generate V3 onion.
I want you to use V3 by default.

e.g.: HidServ /keys/onion/

Scan /keys/onion/,
a1. Is V3 hostname file exist? ===> use V3 only and ignore V2 onion
a2. Is V2 hostname file exist? ===> use V2 only (and ignore V3)
a3. Both file is not exist ===> Then, generate V3 onion.

I've successfully generated "already-exist onion's private key".


MIICXgIBAAKBgQDPquVHKOacJ/fgY6G3vzbO4KgUYxRN5qlaysnKsApWBuGKWyoE
irps1kmiPG1ewAxDYzrQtFzC14f94z8urN64SY8IaRgu76FHS5XeRDQ5AzIi54FH
gHMEhbEReM5gRdxftgMto9Jhi+AoKO/VPhVlaIZyB7C223CiVyc299Qe7QIDAQAB
AoGAalUSAybBNhINDRtW0fQZx0InLhExc1X5P2D4hE0xba0mTSay1BKItHPgzi5s
vghN/y9PDVBc8vNTUb/LOUYQ35SBaEZKw0/TM+rnv/cHvnelPsrkyZmkr5HiQiUM
p4cIwYO3VlF6NsGjhwZ3d0VJXSrsy6lUIYFjZFMB1OJ0H80CQQD/n76S6MHFKv6N
9Imx2NCtQxYU/pbHMdUZOuG2MvpwmbkIYxO85AWxbp+9OMgr1s04kKtT9fhSM1iK
R5/ZSqPDAkEAz/kX1viCd/l2qGD9bfJsd6+TNdsoaply7y7B/pgJZan4tQyi0Vha
CexMW/M+j64hwWdTmP34ewcYbG+45cF3jwJBAPcs9W9C6BOKdmi3m+m/2FChfRnB
7/QfSIrD9/thIe99hYEJpM1Sw/qFGKs028IgS4K1ySU/w+VgRu43QecwGFcCQQCd
ziSIuYhGAMRIf0/NXWVwa4kIFINWX5kWZCRPSo3W1mIg/rWMo72uSd6m5qtR2o9C
cWS9cfhZYcjmft+Ndn+BAkEArSW4oN9RibSh3JG0zstWTF6al6zPuhNxfB57MLaE
HCS2yJf2vvWVTs9ZYBUEZUNX0OJ5doW5kl20gkXrsY4RKw==


I used 4 nvidia GPU and this took about 1 week.
All V2 hosting admins should use V3.

Child Tickets

Change History (2)

comment:1 Changed 18 months ago by dgoulet

Resolution: duplicate
Status: newclosed

This is on the roadmap as soon as we are able to bring v2 feature parity with v3.

comment:2 Changed 14 months ago by teor

This is a duplicate of #27215.

Note: See TracTickets for help on using tickets.