Opened 18 months ago

Last modified 3 months ago

#26080 new defect

torbrowser 7.5.4 update seems to generate file with unique uuid in it

Reported by: cypherpunks Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-easy
Cc: Actual Points:
Parent ID: #18097 Points:
Reviewer: Sponsor:

Description

updating from 7.5.3 to 7.5.4 on linux seems to include a file named '.uuid' in the fonts dir that appears to be unique (comparing two different updated torbrowsers)

Child Tickets

Change History (8)

comment:1 Changed 18 months ago by cypherpunks

Did you get this error?

Fontconfig warning: "/home/debian/tor-browser_en-US/Browser/TorBrowser/Data/fontconfig/fonts.conf", line 145: blank doesn't take any effect anymore. please remove it from your fonts.conf

comment:2 Changed 18 months ago by cypherpunks

Resolution: invalid
Status: newclosed

comment:3 Changed 17 months ago by gk

Resolution: invalid
Status: closedreopened

Do you have steps to reproduce that? I just tested with a clean 7.5.3 and updated to 7.5.4 on a 64bit Debian Jessie system and the fonts folder in the Browser directory does not contain anything besides the expected fonts.

comment:4 Changed 17 months ago by gk

Status: reopenedneeds_information

comment:5 Changed 17 months ago by cypherpunks

FWIW this is the line 145:

142			<int>0xFFF9</int>	<!-- INTERLINEAR ANNOTATION ANCHOR -->
143			<int>0xFFFA</int>	<!-- INTERLINEAR ANNOTATION SEPARATOR -->
144			<int>0xFFFB</int>	<!-- INTERLINEAR ANNOTATION TERMINATOR -->
145		</blank>
146 <!--
147  Rescan configuration every 30 seconds when FcFontSetList is called
148 -->
149		<rescan>
150			<int>30</int>
151		</rescan>
152	</config>

(I'm a regular alpha user and I definitely ended up with this)

comment:6 Changed 17 months ago by cypherpunks

comment:7 Changed 3 months ago by Ephraim

This seems to be related to fontconfig, so this problem might not exist on Windows but Linux and MacOS only? And it might also depend on the versions of the libraries used.

We've found .uuid files in other directories in linux font directories. No idea why that is, but having a .uuid file in a torbrowser-container doesn't feel like a good idea.

The file is created on first start of torbrowser as ./Browser/fonts/.uuid
and once it's created it doesn't change anymore so its mtime shows when this installation has been started the first time and the .uuid contains an actual unique uuid. Feels much like a tag.

I've tested creating a symlink in that place pointing to /dev/null and my torbrowser still works fine without any sideeffects seen.

So my suggestion is to address this issue by creating a symlink

ln -s /dev/null ./Browser/fonts/.uuid

Currently using torbrowser 8.5.3 on debian sid (fontconfig 2.13.1-2)
I'm not using KDE, so it's not related.

comment:8 Changed 3 months ago by gk

Keywords: tbb-easy added
Parent ID: #18097
Status: needs_informationnew

Thanks for the investigation. Anyone wants to write a tiny patch for that? :)

Note: See TracTickets for help on using tickets.