Opened 14 months ago

Closed 14 months ago

Last modified 14 months ago

#26096 closed defect (not a bug)

Not possible to disable DoNoTrack Header in Tor Browser during non-Tor usage

Reported by: loxia_01 Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: noscript
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When TorLauncher is disabled in Tor Browser (to enable bypass of the Tor network), it is no longer possible to control DoNotTrack Header in about:preferences#privacy. DNT Header is always enabled when checking for example on panopticlick.eff.org in spite of setting DoNotTrack to disabled in about:preferences or setting privacy.donottrackheader.enabled to false in about:config.

Disabling or enabling TorButton have no effect on this issue.

This bug seems new in TB version 7.5.4, even though I am not completely sure.


Child Tickets

Change History (5)

comment:1 Changed 14 months ago by loxia_01

Summary: Not possible to disable DoNoTrack Header in Tor Browser for non-Tor usageNot possible to disable DoNoTrack Header in Tor Browser during non-Tor usage

comment:2 Changed 14 months ago by loxia_01

Update: Disabling NoScript restores DNT Header control. Perhaps it has something to do with the latest NoScript update.

comment:3 Changed 14 months ago by cypherpunks

Keywords: noscript added; DNT header removed
Version: Tor: unspecified

comment:4 Changed 14 months ago by gk

Resolution: not a bug
Status: newclosed

We don't support non-Tor usage in Tor Browser. Thus, this is not a Tor Browser bug.

comment:5 Changed 14 months ago by loxia_01

Okay good to know.

Anyway, a workaround is setting noscript.doNotTrack.enabled to false.

Note: See TracTickets for help on using tickets.