Opened 6 months ago

Closed 4 months ago

#26118 closed defect (duplicate)

Import Gecko Console without using shim

Reported by: sysrqb Owned by: dcf
Priority: Medium Milestone:
Component: Obfuscation/meek Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

In Bug 1386535, Firefox 58, Mozilla deleted the devtools/shared/shim/ utils. Meek imports the shim (resource://gre/modules/devtools/Console.jsm), now it should use the new path resource://gre/modules/Console.jsm.

https://developer.mozilla.org/en-US/docs/Tools/Browser_Console#Console.jsm was updated with this new path, too.

Child Tickets

Attachments (1)

0001-Bug-26118-new-path-for-Console.jsm.patch (937 bytes) - added by dcf 6 months ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 6 months ago by dcf

Status: newneeds_review

comment:2 Changed 6 months ago by gk

Parent ID: #25750

comment:3 Changed 4 months ago by gk

Resolution: duplicate
Status: needs_reviewclosed

Duplicate of #26477.

Note: See TracTickets for help on using tickets.