Opened 17 months ago

Closed 17 months ago

Last modified 17 months ago

#26134 closed defect (not a bug)

HTTPS - ORport

Reported by: root@… Owned by: phoul
Priority: Medium Milestone:
Component: Community/Tor Support Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Why am I always connected to the same IP address: 51.15.89.218:https ???
The IP never changes

lsof -i -nn
COMMAND  PID USER   FD   TYPE DEVICE SIZE/OFF NODE NAME
arm     2115 root    4u  IPv4  28875      0t0  TCP 127.0.0.1:55676->127.0.0.1:9052 (ESTABLISHED)
tor     2142 root    6u  IPv4  30825      0t0  TCP 127.0.0.1:9050 (LISTEN)
tor     2142 root    7u  IPv4  30826      0t0  TCP 127.0.0.1:9052 (LISTEN)
tor     2142 root   10u  IPv4  30828      0t0  TCP 127.0.0.1:9052->127.0.0.1:55676 (ESTABLISHED)
tor     2142 root   13u  IPv4  28053      0t0  TCP 192.168.0.3:48830->51.15.89.218:https (ESTABLISHED)
chrome  5483 root  218u  IPv4 414173      0t0  TCP 127.0.0.1:50376->127.0.0.1:9050 (CLOSE_WAIT)
chrome  5483 root  285u  IPv4 413278      0t0  TCP 127.0.0.1:50378->127.0.0.1:9050 (CLOSE_WAIT)

Tor with client support

tor -v
May 19 03:01:43.116 [notice] Tor 0.3.2.9 (git-9e8b762fcecfece6) running on Linux with Libevent 2.0.21-stable, OpenSSL 1.0.2g, Zlib 1.2.8, Liblzma N/A, and Libzstd N/A.

Child Tickets

Change History (3)

comment:1 Changed 17 months ago by teor

Component: - Select a componentCommunity/Tor Support
Milestone: Tor: 0.3.2.x-final
Owner: set to phoul
Resolution: not a bug
Status: newclosed
Type: enhancementdefect
Version: Tor: 0.3.2.9

Tor uses a small number of entry guards to protect your anonymity:
https://www.torproject.org/docs/faq.html.en#EntryGuards

comment:2 Changed 17 months ago by root@…

Protecting my anonymity by using a small number of entry guards?

All my connections go through the entry guard (always the same guard), this can be used to spy on every Tor user by a "Man in the middle attack".

How can i setup Tor to change the entry guards all the time?

comment:3 Changed 17 months ago by teor

Tor's entry guard design minimises your chance of choosing a malicious entry node.
Choosing entry nodes at random guarantees you will eventually choose a bad one,

This is a bug tracker, not a question and answer platform.
If you have more questions, please use IRC or the tor-talk mailing list for help.
https://www.torproject.org/about/contact.html.en

Note: See TracTickets for help on using tickets.