Opened 4 months ago

Closed 3 months ago

#26157 closed defect (fixed)

Text captcha does not obey order of operations

Reported by: cypherpunks Owned by: qbi
Priority: Low Milestone:
Component: Internal Services/Service - trac Version:
Severity: Normal Keywords:
Cc: dmr Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The text captcha asks a simple math question, for example:

six plus two multiplied by four

The correct answer is 6 + 2 × 4 = 6 + 8 = 15, due to order of operations, but the captcha system does not accept that and instead expects you to do (6 + 2) × 4 = 8 × 4 = 32. This is confusing to many users who do multiplication first, as they should. Please explicitly specify that order of operations is ignored, or do not ignore the order of operations. Or accept both answers to the ambiguous question (e.g. both 15 and 32).

I tried to post this on https://trac.edgewall.org/newticket, but they have blocked submissions by Tor users. I am posting it here instead in case there is a possible workaround on Tor's side.

Child Tickets

Change History (5)

comment:1 Changed 4 months ago by cypherpunks

Resolution: duplicate
Status: newclosed

Closing as duplicate of https://trac.edgewall.org/ticket/13031 (kindly posted by another user).

comment:2 Changed 4 months ago by dmr

Cc: dmr added

I tried to post this on ​https://trac.edgewall.org/newticket, but they have blocked submissions by Tor users. I am posting it here instead in case there is a possible workaround on Tor's side.

Filed at:
https://trac.edgewall.org/ticket/13031

(For what it's worth, I used Tor Browser to file that ticket.)

comment:3 Changed 4 months ago by cypherpunks

How did you file that ticket using Tor? It blocked me when I attempted to do so.

comment:4 Changed 3 months ago by teor

Resolution: duplicate
Status: closedreopened

In the meantime, we can mitigate this bug by limiting ourselves to two terms, rather than three.

comment:5 Changed 3 months ago by teor

Resolution: fixed
Status: reopenedclosed

Done in trac admin.

Note: See TracTickets for help on using tickets.