#26208 closed defect (duplicate)

Bug: Non-fatal assertion info failed in onion_extend_cpath Tor 0.3.3.6

Reported by: Dbryrtfbcbhgf Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: #25692 Points:
Reviewer: Sponsor:

Description

When I start a onion service I keep geeking this error, I attached the full log.
May 25 16:14:02.000 [warn] Bug: Non-fatal assertion info failed in onion_extend_cpath at src/or/circuitbuild.c:2779. Stack trace: (on Tor 0.3.3.6 7dd0813e783ae16e)
May 25 16:14:02.000 [warn] Bug: 0 tor 0x000000010cb5836b log_backtrace + 73 (on Tor 0.3.3.6 7dd0813e783ae16e)
May 25 16:14:02.000 [warn] Bug: 1 tor 0x000000010cb6fe75 tor_bug_occurred_ + 266 (on Tor 0.3.3.6 7dd0813e783ae16e)
May 25 16:14:02.000 [warn] Bug: 2 tor 0x000000010ca4da7a circuit_establish_circuit + 2340 (on Tor 0.3.3.6 7dd0813e783ae16e)
May 25 16:14:02.000 [warn] Bug: 3 tor 0x000000010ca6238b circuit_get_open_circ_or_launch + 2119 (on Tor 0.3.3.6 7dd0813e783ae16e)
May 25 16:14:02.000 [warn] Bug: 4 tor 0x000000010ca616cc connection_ap_handshake_attach_circuit + 1003 (on Tor 0.3.3.6 7dd0813e783ae16e)
May 25 16:14:02.000 [warn] Bug: 5 tor 0x000000010ca81b12 connection_ap_attach_pending + 195 (on Tor 0.3.3.6 7dd0813e783ae16e)
May 25 16:14:02.000 [warn] Bug: 6 tor 0x000000010ca5f538 circuit_build_needed_circs + 57 (on Tor 0.3.3.6 7dd0813e783ae16e)
May 25 16:14:02.000 [warn] Bug: 7 tor 0x000000010caece07 second_elapsed_callback + 803 (on Tor 0.3.3.6 7dd0813e783ae16e)
May 25 16:14:02.000 [warn] Bug: 8 libevent-2.1.6.dylib 0x000000010ccbf9c2 event_process_active_single_queue + 1057 (on Tor 0.3.3.6 7dd0813e783ae16e)
May 25 16:14:02.000 [warn] Bug: 9 libevent-2.1.6.dylib 0x000000010ccbccb3 event_base_loop + 1074 (on Tor 0.3.3.6 7dd0813e783ae16e)
May 25 16:14:02.000 [warn] Bug: 10 tor 0x000000010caec865 do_main_loop + 1377 (on Tor 0.3.3.6 7dd0813e783ae16e)
May 25 16:14:02.000 [warn] Bug: 11 tor 0x000000010caeebf5 tor_run_main + 174 (on Tor 0.3.3.6 7dd0813e783ae16e)
May 25 16:14:02.000 [warn] Bug: 12 tor 0x000000010cb5420d tor_main + 70 (on Tor 0.3.3.6 7dd0813e783ae16e)
May 25 16:14:02.000 [warn] Bug: 13 tor 0x000000010ca3a253 main + 27 (on Tor 0.3.3.6 7dd0813e783ae16e)
May 25 16:14:02.000 [warn] Bug: 14 libdyld.dylib 0x00007fff51c9a015 start + 1 (on Tor 0.3.3.6 7dd0813e783ae16e)

Child Tickets

Attachments (1)

tor bug.rtf (50.1 KB) - added by Dbryrtfbcbhgf 20 months ago.

Download all attachments as: .zip

Change History (3)

Changed 20 months ago by Dbryrtfbcbhgf

Attachment: tor bug.rtf added

comment:1 Changed 20 months ago by Dbryrtfbcbhgf

  • Correction.

I keep getting this error

comment:2 Changed 20 months ago by teor

Parent ID: #25692
Resolution: duplicate
Status: newclosed

This is a duplicate of #25692. Please use 0.3.2 or 0.3.4.1-alpha until it is backported to 0.3.3.

Note: See TracTickets for help on using tickets.