#26218 closed enhancement (duplicate)

Enable TLS session tickets on a per-circuit basis

Reported by: cypherpunks Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

TLS session tickets were disabled in #4099 to reduce the risk of tracking. Since then, circuit isolation has progressed significantly. I propose re-enabling TLS session tickets, but only for individual circuits. This will provide the connection handshake speedups while avoiding the risk of fingerprinting.

Child Tickets

Change History (1)

comment:1 Changed 16 months ago by gk

Resolution: duplicate
Status: newclosed

Duplicate of #17252.

Note: See TracTickets for help on using tickets.