#26230 closed task (fixed)

Release ExoneraTor 2.1.0

Reported by: karsten Owned by: metrics-team
Priority: Medium Milestone: ExoneraTor 2.1.0
Component: Metrics/ExoneraTor Version:
Severity: Normal Keywords:
Cc: metrics-team Actual Points:
Parent ID: Points:
Reviewer: iwakeh,irl Sponsor:

Description

Let's release a new ExoneraTor version that contains the #26163 change.

I'm going to prepare a pre-release tarball now.

Child Tickets

Change History (7)

comment:1 Changed 16 months ago by karsten

Summary: Release ExoneraTor 2.0.3Release ExoneraTor 2.1.0

Or maybe it's rather going to be 2.1.0 with the dependency update.

comment:2 Changed 16 months ago by karsten

Status: newneeds_review

comment:3 Changed 16 months ago by iwakeh

Reviewer: iwakeh,irl

comment:4 Changed 16 months ago by iwakeh

The release tarball is ok, all checks and tests pass, bytecode reproducible.

When inspecting the release branch I noticed two (minor) issues:

The following change replaces catching of the RuntimeException by catching IOException. I think, we introduced the catch-RE in order to always have null returned in case of an unforseen error and _not_ excalate any exception. Maybe add the catch-RE again, because we don't know what issues could cause jackson to throw a RE?

@@ -107,7 +99,7 @@ public class QueryResponse {
         return null;
       }
       return response;
-    } catch (RuntimeException e) {
+    } catch (IOException e) {
       logger.error("JSON decoding failed.", e);
     }
     return null;

And, the change log could state that the superfluous brackets caused broken links? But that's really nitpicking.

comment:5 Changed 16 months ago by karsten

Both good suggestions!

New ExoneraTor branch: ​​​​​​​https://gitweb.torproject.org/user/karsten/exonerator.git/log/?h=task-26230-2

New pre-release tarball: ​​​​​​​https://people.torproject.org/~karsten/volatile/exonerator-2.1.0-pre1.tar.gz

Please take another look, if you can!

comment:6 Changed 16 months ago by iwakeh

Status: needs_reviewmerge_ready

Thanks for adding the changes.

The pre-release looks fine!

comment:7 Changed 16 months ago by karsten

Milestone: ExoneraTor 2.1.0
Resolution: fixed
Status: merge_readyclosed

Released and deployed. Closing.

Note: See TracTickets for help on using tickets.