Opened 7 months ago

Closed 7 months ago

#26235 closed defect (fixed)

Help menu does not open in Tor Browser nightlies based on ESR60

Reported by: gk Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: ff60-esr, TorBrowserTeam201805R
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When trying to open the Help menu after clicking on the "Hamburger menu" just a blank pane shows up and one sees

JavaScript error: chrome://browser/content/utilityOverlay.js, line 849: TypeError: document.getElementById(...) is null

in the terminal

Child Tickets

Change History (2)

comment:1 Changed 7 months ago by mcs

Keywords: TorBrowserTeam201805R added
Status: newneeds_review

The JS errors occur because Mozilla added code inside browser/base/content/utilityOverlay.js that assumes that the feedbackPage and helpSafeMode elements are present (see the buildHelpMenu function). Here is a possible fix:
https://gitweb.torproject.org/user/brade/torbutton.git/commit/?h=bug26235-01&id=c63f7d9f65927919bb57011a21e7951d65fd2df3

Kathy and I confirmed that it makes the JS errors disappear, but we did not test the patch on Linux. Maybe someone who has an up-to-date ESR60-based Linux build can do that while reviewing this patch.

comment:2 Changed 7 months ago by gk

Resolution: fixed
Status: needs_reviewclosed

Looks good to me. I changed the commit message a bit as we don't do the rebase thing in the torbutton repo (thus using fixup is not so beneficial). Rather, just showing the current bug number for reference seems like a good thing to me. Commit 66048f2ad3c2708aec11d7414ec189e868c0d487 on master has the fix.

Note: See TracTickets for help on using tickets.