Opened 13 months ago

Last modified 13 months ago

#26309 needs_information defect

Lost previous tabs when updated to 7.5.4

Reported by: artemik Owned by: tbb-team
Priority: Low Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

In my previous Tor version (don't know what it was), I set Tor to open tabs from previous session on startup, keep history, etc.

Today I've updated to Tor 7.5.4. All my tabs, the history are gone. The setting isn't available anymore.

Why didn't I get ANY warning on such destructive behavior?

I know, privacy and all that stuff, but you shouldn't limit the users. Make it the default and allow customization. But anyway, you should at least notify about it. I don't use the browser for "dark" stuff - I use it just as something that allows me to open websites not available in my country.

Now I lost all my tabs. How am I supposed to restore them?

Child Tickets

Change History (5)

comment:1 Changed 13 months ago by artemik

Correction - the setting is there, I managed to revert it back.
But the tabs are gone anyway, and the setting shouldn't have reset to the default, it should've been the one I had before, i.e. keep history and tabs.

comment:2 Changed 13 months ago by artemik

My tabs are back. But it's weird. Because:

  1. I decided, since I can never restore my tabs back, I opened new ones.
  2. Finished working, closed the browser.
  3. Opened the browser again, it restored the tabs I opened at step 1.
  4. Again, finished working, closed the browser.
  5. Open the browser, and now it restored not the tabs from step 1, but those that I lost when updated to the new versions. I'm actually happy with that, but still it's weird it hasn't restored the tabs that are really last session tabs, i.e. from step 1.

Between all the steps several minutes passed. So it eliminates any RAM caching problem possibilities or browser not being able to exit completely.

comment:3 Changed 13 months ago by arma

Component: - Select a componentApplications/Tor Browser
Owner: set to tbb-team

comment:4 Changed 13 months ago by arma

Sounds like you're using Tor Browser in an unusual configuration, so you could easily be running into bugs that few other people (and no Tor Browser devs) run into.

I don't think Tor Browser is meant to be broken in this way (i.e. discard things that you configured it to not discard), but you're going to need to provide clear steps to reproduce your problem, before the devs will have a chance of figuring out what went wrong. What exactly did you change in the configurations? Can you throw out your current Tor Browser, start with the old one, retrace those steps, and then see if it happens to you again?

comment:5 Changed 13 months ago by gk

Priority: MediumLow
Status: newneeds_information
Note: See TracTickets for help on using tickets.