Opened 8 years ago

Closed 8 years ago

Last modified 21 months ago

#2633 closed defect (worksforme)

"Torbutton Exception in sandbox evaluation. Date hooks not applied" still there

Reported by: bouazza Owned by: mikeperry
Priority: Immediate Milestone:
Component: Applications/Torbutton Version: Torbutton: 1.3.0-alpha
Severity: Normal Keywords: TorbuttonIterationFires20110305 MikePerryIterationFires20110305
Cc: Actual Points: 1
Parent ID: Points: 1
Reviewer: Sponsor:

Description

I'm using the latest version of Torbutton from git with Firefox 4.0b11, and in fact, the number of those annoying popups decreased a lot ( see #2421 ), but they are still there.

I noticed however that the error message changed, now I get popups with :

"Torbutton Exception in sandbox evaluation. Date hooks not applied:
Error: Permission denied to access property 'window'"

Child Tickets

Change History (19)

comment:1 Changed 8 years ago by mikeperry

Can you reproduce on a particular site? Also, are you really sure you're using latest git? The latest git commit was on 2011-02-23 when I fixed another round of these specific to 4.0b11
156e3a62ffaebc55d8b8b10b54b9567ad9d1b608 as part of bug #2465.

What git hash do you have?

comment:2 Changed 8 years ago by mikeperry

Actually, 0b96be3008ff894bf1e04dbf96103da78b601013 is the git hash that fixed this issue in 4.0b11 for me.

comment:3 Changed 8 years ago by bouazza

I didn't use a git client ( I don't know how to use one ) so I can't give you my git hash, I just downloaded the latest origin/master snapshot yesterday using this link : https://gitweb.torproject.org/torbutton.git/snapshot/refs/heads/master.tar.gz , then built the hole thing with makexpi.sh .

I see those messages in Ajax-ified websites in majority ( I don't know if it is only js sites who trigger those popups ), mostly in Facebook.

comment:4 Changed 8 years ago by mikeperry

Can you run the command 'sha1sum' on the master.tar.gz you downloaded yesterday and verify that it is the same sha1sum from a fresh master.tar.gz that you download today?

Can you also paste both sha1sum output values here, so I can verify I am using the same version if I try to hunt down a reproduction case on my own?

comment:5 Changed 8 years ago by bouazza

Something weird is happening, the hash of the tarball I downloaded yesterday is 11eee10e7d2f6dc5c48dca1f98526bd71ea183b7 , whereas the hash of the one I downloaded right now is 94f95a31d9d783ceb030b96f2fb4806e61dbbb39 ( changing every time I download another one even if in the git logs nothing did change )... But both have the same "Last modified" date ( 24 Feb 7:38 , which is the same as the one displayed in gitweb "Thu, 24 Feb 2011 07:38:25" ), and both have the same name "torbutton-master-156e3a6".

Anyway, still the same result with both snapshots.

comment:6 Changed 8 years ago by mikeperry

Ok, cool. We've got a git hash then. That 156e3c6 is what identifies the git revision (note that it is the prefix of the hash I first pasted).

Can you get the error to happen on any other sites that don't require a login to test? I don't use facebook. If it is just ajax stuff, I bet Google Maps might be a nice one to try.

comment:7 Changed 8 years ago by bouazza

Hum... I tried Google Maps and some random sites with Ajax, and the popups don't show up. So maybe it's because of SSL ? I'm using https with Facebook ( for anonymity reasons ), maybe that's the source of the problems ?
It happens on Twitter with https too, but very rarely.
Why not create a Facebook test account ? It's very easy to reproduce :-)

comment:8 Changed 8 years ago by mikeperry

Mostly the principle of it ;). If I do try facebook, is it every page, or only certain pages?

Are you also using https everywhere, btw?

comment:9 Changed 8 years ago by bouazza

It is on every page, and yes I'm using HTTPS-Everywhere.

comment:10 Changed 8 years ago by mikeperry

Keywords: TorbuttonIterationFires20110305 MikePerryIterationFires20110305 added
Priority: normalblocker
Status: newaccepted

comment:11 Changed 8 years ago by mikeperry

Whee. 4.0b12 is out. Don't suppose this magically went away (or got worse?)

comment:12 Changed 8 years ago by faisal

From my perspective, it got worse -- it used to throw one 1-3 dialogs per page, and now it's more like 5-10. This is tested without HTTPS Everywhere.

comment:13 Changed 8 years ago by mikeperry

faisai: are you using that same git hash mentioned above? We fixed an instance in git that hasn't been released yet. Can you get this to happen anywhere but facebook?

comment:14 Changed 8 years ago by faisal

I hadn't tried that git hash. Doing so appears to fix the problem.

FWIW, I'd been seeing the problem everywhere, not just Facebook. I'm not sure I'd tried it on Facebook.

comment:15 Changed 8 years ago by mikeperry

I've been tricked into creating a facebook account! This bug does not happen for me on FF4.0b12 with HTTPS Everywhere installed on any of pages of the suggested friends it gave me.

Either FF4.0b12 fixed the issue, or there is some other addon conflict at work here. I am using the latest torbutton git and also the latest https everywhere devel (0.9.9devel3).

comment:16 Changed 8 years ago by bouazza

Hum, it seems that indeed FF4.0b12 fixed the issue.

Thanks !

comment:17 Changed 8 years ago by mikeperry

Resolution: worksforme
Status: acceptedclosed

comment:18 Changed 8 years ago by mikeperry

Actual Points: 1
Points: 1

comment:19 Changed 21 months ago by teor

Severity: Normal

Set all tickets without a severity to "Normal"

Note: See TracTickets for help on using tickets.