Opened 4 months ago

Closed 4 months ago

#26396 closed defect (fixed)

libwinpthread we ship in Windows builds is not built reproducible

Reported by: gk Owned by: tbb-team
Priority: Very High Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: ff60-esr, tbb-rbm, TorBrowserTeam201806R
Cc: boklm Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

While comparing the 64bit esr60-based builds done on two different machines it turned out building libwinpthread-1.dll is not reproducible. The diff is small, though:

--- /dev/fd/63	2018-06-18 11:22:09.192115654 +0200
+++ /dev/fd/62	2018-06-18 11:22:09.192115654 +0200
@@ -6,12 +6,12 @@
 00000050: 6973 2070 726f 6772 616d 2063 616e 6e6f  is program canno
 00000060: 7420 6265 2072 756e 2069 6e20 444f 5320  t be run in DOS 
 00000070: 6d6f 6465 2e0d 0d0a 2400 0000 0000 0000  mode....$.......
-00000080: 5045 0000 6486 1400 b95a 195b 003e 0800  PE..d....Z.[.>..
+00000080: 5045 0000 6486 1400 7e44 165b 003e 0800  PE..d...~D.[.>..
 00000090: 6e08 0000 f000 2620 0b02 021a 007c 0000  n.....& .....|..
 000000a0: 004e 0000 000a 0000 4013 0000 0010 0000  .N......@.......
 000000b0: 0000 9464 0000 0000 0010 0000 0002 0000  ...d............
 000000c0: 0400 0000 0000 0000 0500 0200 0000 0000  ................
-000000d0: 0010 0900 0006 0000 3cb6 0900 0300 0000  ........<.......
+000000d0: 0010 0900 0006 0000 c089 0900 0300 0000  ................
 000000e0: 0000 2000 0000 0000 0010 0000 0000 0000  .. .............
 000000f0: 0000 1000 0000 0000 0010 0000 0000 0000  ................
 00000100: 0000 0000 1000 0000 00e0 0000 df10 0000  ................
@@ -2622,7 +2622,7 @@
 0000a3d0: 0000 0000 0000 0000 0000 0000 0000 0000  ................
 0000a3e0: 0000 0000 0000 0000 0000 0000 0000 0000  ................
 0000a3f0: 0000 0000 0000 0000 0000 0000 0000 0000  ................
-0000a400: 0000 0000 b95a 195b 0000 0000 6ee5 0000  .....Z.[....n...
+0000a400: 0000 0000 7e44 165b 0000 0000 6ee5 0000  ....~D.[....n...
 0000a410: 0100 0000 8700 0000 8700 0000 28e0 0000  ............(...
 0000a420: 44e2 0000 60e4 0000 f045 0000 a01c 0000  D...`....E......
 0000a430: b051 0000 0059 0000 2054 0000 40d0 0000  .Q...Y.. T..@...

Child Tickets

Change History (5)

comment:1 Changed 4 months ago by gk

Keywords: tbb-rbm added

comment:2 Changed 4 months ago by gk

Looks like a different timestamp.

comment:3 Changed 4 months ago by boklm

Maybe we need to add -Wl,--no-insert-timestamp to LDFLAGS when building mingw-w64-pthread.

comment:4 Changed 4 months ago by boklm

Keywords: TorBrowserTeam201806R added; TorBrowserTeam201806 removed
Status: newneeds_review

There is a patch for review in branch bug_26396:
https://gitweb.torproject.org/user/boklm/tor-browser-build.git/commit/?h=bug_26396&id=5a43ceb3e0f3379f13764a8cd87d469fa7d774ed

After building mingw-w64 for Windows 64 on two machines with this patch, I get the same libwinpthread-1.dll.

comment:5 Changed 4 months ago by gk

Resolution: fixed
Status: needs_reviewclosed

Looks good to me, thanks. Merged to master with commit 5a43ceb3e0f3379f13764a8cd87d469fa7d774ed.

Note: See TracTickets for help on using tickets.