#26423 closed defect (duplicate)

Tor 7.5.5 crashes after opening

Reported by: jllover Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version: Tor: unspecified
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

After opening Tor, moving the mouse over a tab or over the hamburger menu on the right causes a Tor crash. In some cases, this happens before I enter a URL. Windows error reporting shows the following:
Faulting application name: firefox.exe, version: 52.8.1.6607, time stamp: 0x00000000
Faulting module name: mozglue.dll, version: 52.8.1.6607, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x000034a7
Faulting process id: 0x1e60
Faulting application start time: 0x01d4083d5977c60b
Faulting application path: C:\Development\Tor Browser\Browser\firefox.exe
Faulting module path: C:\Development\Tor Browser\Browser\mozglue.dll
Report Id: ce384295-7430-11e8-b607-0021919111a5

Child Tickets

Change History (5)

comment:1 Changed 17 months ago by jllover

This is occurring on Windows 7 Ultimate.

comment:2 Changed 17 months ago by jllover

Component: Core TorApplications/Tor Browser
Owner: set to tbb-team

comment:3 Changed 17 months ago by jllover

I found one different crash in the Application Log with d2d1.dll as the faulting module:
Faulting application name: firefox.exe, version: 52.8.1.6607, time stamp: 0x00000000
Faulting module name: d2d1.dll, version: 6.2.9200.16765, time stamp: 0x528bf6b2
Exception code: 0xc0000005
Fault offset: 0x002cf8cb
Faulting process id: 0x608
Faulting application start time: 0x01d4083cccafd2d1
Faulting application path: C:\Development\Tor Browser\Browser\firefox.exe
Faulting module path: C:\Windows\system32\d2d1.dll
Report Id: 213bd9a7-7430-11e8-b607-0021919111a5

comment:4 Changed 17 months ago by cypherpunks

Faulting module name: mozglue.dll

#22960

Faulting module name: d2d1.dll

#9145

comment:5 Changed 17 months ago by gk

Resolution: duplicate
Status: newclosed

Makring this as duplicate of #9145.

Note: See TracTickets for help on using tickets.