Opened 9 years ago

Closed 8 years ago

Last modified 3 years ago

#2643 closed enhancement (fixed)

Cron job to pull translations from Transifex

Reported by: runa Owned by: sebastian
Priority: Medium Milestone:
Component: Community/Translations Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

At the moment, translations from Transifex are only pulled and committed when I remember to do it. I would like to see a cron job take over this task.

We will need to have a user with commit access to the following projects:

BridgeDB: https://gitweb.torproject.org/bridgedb.git/

GetTor: https://svn.torproject.org/svn/projects/gettor/po/

Vidalia Help Files: https://svn.torproject.org/vidalia/vidalia/trunk/src/vidalia/help/content/po/

Vidalia Installer: https://svn.torproject.org/vidalia/vidalia/trunk/pkg/win32/po/

Vidalia: https://svn.torproject.org/vidalia/vidalia/trunk/src/vidalia/i18n/po/

The Manual Pages, Orbot, Torbutton-alpha, Torbutton, Torcheck and the Website: https://svn.torproject.org/svn/translation/trunk/projects/

That user will also need to have the Transifex client installed. See http://help.transifex.net/user-guide/client/index.html#user-client for info on how to install it.

Due to server-side restrictions, we cannot pull translations for all the projects at the same time. What we can do is pull translations for a new project every hour, or something similar.

Child Tickets

Change History (11)

comment:1 Changed 9 years ago by runa

Ok, seems like Transifex fixed their server-side-restriction-issue. All we need now is a cron job that pulls translations for all those projects and commits them to SVN/Git.

comment:2 Changed 9 years ago by runa

Owner: changed from weasel to sebastian
Status: newassigned

comment:3 Changed 8 years ago by runa

I remembered that you might want to pull the source files (the .pot files inside the templates directory) as well. Run tx pull --help or something similar to get the right syntax.

comment:4 Changed 8 years ago by Sebastian

ah thanks, will check that out

comment:5 Changed 8 years ago by Sebastian

Resolution: fixed
Status: assignedclosed

Implemented. Currently only bridgedb and orbot can be pulled automatically due to a transifex bug, but I hope that'll be resolved eventually.

comment:6 in reply to:  5 Changed 8 years ago by runa

Resolution: fixed
Status: closedreopened

Replying to Sebastian:

Implemented. Currently only bridgedb and orbot can be pulled automatically due to a transifex bug, but I hope that'll be resolved eventually.

I'm going to re-open this to say that I've changed a few things for Orbot. We now pull .xml files instead of .po files, so you'll need to update your cron. See #3987 for details.

comment:7 Changed 8 years ago by runa

And oh, we've decided to drop website translations. See #4082 for details. The cron job should only pull translations for: Vidalia, Vidalia-alpha, Vidalia Help, Vidalia Installer, BridgeDB, GetTor, Orbot, Torbutton, TorCheck.

comment:8 Changed 8 years ago by Sebastian

I just wrote a patch for the transifex issue preventing us from using the cron job for every project we have. It sits in their review queue, hope to get it applied soon (the problem is that it is a server-side patch, so we can't benefit until they've updated)

comment:9 Changed 8 years ago by Sebastian

I updated the orbot stuff

comment:10 Changed 8 years ago by Sebastian

Resolution: fixed
Status: reopenedclosed

Eh, fixed

comment:11 Changed 3 years ago by isabela

Component: User Experience/TranslationsCommunity/Translations
Note: See TracTickets for help on using tickets.