Opened 18 months ago

Closed 18 months ago

Last modified 16 months ago

#26465 closed defect (fixed)

Localized bundles are only showing en-US text

Reported by: gk Owned by: tbb-team
Priority: Very High Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: TorBrowserTeam201806, GeorgKoppen201806
Cc: boklm Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

All of our localized bundles are broken with the switch to Firefox 60.1.0 ESR. Once a localized bundle is starting up only en-US text is shown. Looking at the language packs state in about:addons it shows that it got disabled as it is unsigned. I suspect this is due to https://bugzilla.mozilla.org/show_bug.cgi?id=1454141. So, it seems Mozilla is not providing signed language packs in their candidate builds right now. :(

Child Tickets

Change History (3)

comment:1 Changed 18 months ago by gk

Actually, Mozilla provides signed language packs. The problem is that we modify them during the bundling step:

# Prepare our language packs for using the proper search engines and embed
# our default bookmarks. See bugs 18915 and 21879 for more details.

I guess what we need at the end is signing the lang packs we ship with our own key, *sigh*.

comment:2 Changed 18 months ago by gk

Keywords: GeorgKoppen201806 added
Resolution: fixed
Status: newclosed

I pushed a fixup commit to tor-browser-60.1.0esr-8.0-1 for now to unblock our builds (commit a0efd2fcd6e945919b46c9204846b14cdcc188bb). Let me know if I messed up. I'll file a follow-up ticket for work on a better solution.

comment:3 Changed 16 months ago by gk

FWIW depending on how we move forward #26553 and #26843 might be the relevant bugs.

Note: See TracTickets for help on using tickets.