Opened 5 months ago

Closed 5 months ago

#26472 closed defect (duplicate)

Generating incremental mars for tbb-8.0a9-build2 fails

Reported by: boklm Owned by: tbb-team
Priority: Very High Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: TorBrowserTeam201806
Cc: mcs, brade Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Generating incremental mars for tbb-8.0a9-build2 fails with the following error:

$ make incrementals-alpha                                                                                                               
git submodule update --init
./rbm/rbm build release --step update_responses_config --target alpha --target create_unsigned_incrementals
tools/update-responses/download_missing_versions alpha
MAR_OLD_FORMAT=1 tools/update-responses/gen_incrementals alpha
Starting tor-browser-linux32-8.0a8-8.0a9_ru.incremental.mar
Starting tor-browser-linux32-8.0a8-8.0a9_nl.incremental.mar
Starting tor-browser-linux32-8.0a8-8.0a9_en-US.incremental.mar
Starting tor-browser-linux32-8.0a8-8.0a9_zh-CN.incremental.mar
Starting tor-browser-linux32-8.0a8-8.0a9_it.incremental.mar
Starting tor-browser-linux32-8.0a8-8.0a9_fa.incremental.mar
Starting tor-browser-linux32-8.0a8-8.0a9_pl.incremental.mar
Starting tor-browser-linux32-8.0a8-8.0a9_vi.incremental.mar
Starting tor-browser-linux32-8.0a8-8.0a9_pt-BR.incremental.mar
Error: making incremental mar:

Error: Error creating tor-browser-linux32-8.0a8-8.0a9_en-US.incremental.mar
Makefile:120: recipe for target 'incrementals-alpha' failed
make: *** [incrementals-alpha] Error 1
Error: making incremental mar:
Can't exec "make_incremental_update.sh": No such file or directory at /usr/share/perl5/IO/CaptureOutput.pm line 73.

Error: making incremental mar:
Can't exec "make_incremental_update.sh": No such file or directory at /usr/share/perl5/IO/CaptureOutput.pm line 73.

Error: making incremental mar:
Can't exec "make_incremental_update.sh": No such file or directory at /usr/share/perl5/IO/CaptureOutput.pm line 73.

Error: making incremental mar:
Can't exec "make_incremental_update.sh": No such file or directory at /usr/share/perl5/IO/CaptureOutput.pm line 73.

Error: making incremental mar:
Can't exec "make_incremental_update.sh": No such file or directory at /usr/share/perl5/IO/CaptureOutput.pm line 73.

Error: making incremental mar:
Can't exec "make_incremental_update.sh": No such file or directory at /usr/share/perl5/IO/CaptureOutput.pm line 73.

Error: making incremental mar:
Can't exec "make_incremental_update.sh": No such file or directory at /usr/share/perl5/IO/CaptureOutput.pm line 73.

Child Tickets

Attachments (1)

0001-fixup-Bug-4234-Use-the-Firefox-Update-Process-for-To.patch (2.3 KB) - added by boklm 5 months ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 5 months ago by gk

As a data point: this happens for me as well but not with copied over mar-tools from older releases. It seems something in the script got changed from ESR52-ESR60. Let's see what exactly...

comment:2 Changed 5 months ago by boklm

Cc: mcs brade added

It seems to be related to adding set -e at the beginning of the make_incremental_update.sh script (#24476).

There are some places where the output of some commands is expected to be something else than 0:

  # NoScript is a packed extension, so we simply compare the old and the new
  # .xpi files.
  noscript_path="$ext_path/$noscript"
  diff -a "$olddir/$noscript_path" "$newdir/$noscript_path" > /dev/null
  rc=$?
  if [ $rc -gt 1 ]; then
    notice "Unexpected exit $rc from $noscript_path diff command"
    exit 2
  elif [ $rc -eq 1 ]; then
    requested_forced_updates="$requested_forced_updates $noscript_path"
  fi

With set -e the script exits immediately when the diff command fails.

I think we should disable set -e in those places.

comment:3 Changed 5 months ago by boklm

I attached a patch that should fix the issue. I will now try to generate incrementals with a make_incremental_update.sh updated by this patch.

comment:4 Changed 5 months ago by boklm

I still get the same error after manually updating alpha/unsigned/8.0a9-build3/mar-tools-linux64.zip to apply this patch. So it seems there might be more than one issue.

comment:5 Changed 5 months ago by boklm

As a workaround to be able to generate incrementals for this release, we can manually extract mar-tools-linux64.zip, remove the set -e line from make_incremental_update.sh, update mar-tools-linux64.zip and move it back to alpha/unsigned/8.0a9-build3. After this generating the incrementals is working.

I uploaded my sha256sums-unsigned-build.incrementals.txt at:
https://people.torproject.org/~boklm/builds/8.0a9-build3/

comment:6 Changed 5 months ago by gk

Resolution: duplicate
Status: newclosed

Closing this as duplicate of #26216.

Note: See TracTickets for help on using tickets.