Opened 2 years ago

Closed 2 years ago

#26479 closed defect (fixed)

Fix 0.3.4: appveyor failures on win32 (test_dir)

Reported by: nickm Owned by: nickm
Priority: High Milestone: Tor: 0.3.4.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: asn Sponsor:

Description

There are two problems on windows right now: test_dir.c fails with warnings, and the geoip tests are still failing.

This is the ticket for the test_dir fix. Both will be on the same branch.

Child Tickets

TicketStatusOwnerSummaryComponent
#26480closednickmFix 0.3.4: appveyor failures on win32 (geoip binary mode)Core Tor/Tor

Change History (4)

comment:1 Changed 2 years ago by nickm

Status: assignedneeds_review

See branch appveyor_fix_0623 for this ticket and its child, both apparently caused by my fixes for #25787.

PR at https://github.com/torproject/tor/pull/176.

This pair of bugs is a release-blocker for 0.3.4.3-alpha.

comment:2 Changed 2 years ago by asn

Reviewer: asn

comment:3 Changed 2 years ago by asn

Status: needs_reviewmerge_ready

Fixes LGTM, and appveyor seems to agree! Let's go!

comment:4 Changed 2 years ago by nickm

Resolution: fixed
Status: merge_readyclosed

Merged to 0.3.4 and forward!

Note: See TracTickets for help on using tickets.