Opened 11 months ago

Closed 11 months ago

Last modified 11 months ago

#26486 closed defect (wontfix)

Grey out DNT options so the user can't disable it by accident

Reported by: cypherpunks Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

TBB 8 (60) series

You need to lock "Send websites a “Do Not Track” signal that you don’t want to be tracked" option to "Always".

Child Tickets

Attachments (1)

dnt.jpg (18.8 KB) - added by cypherpunks 11 months ago.
DNT

Download all attachments as: .zip

Change History (6)

Changed 11 months ago by cypherpunks

Attachment: dnt.jpg added

DNT

comment:1 Changed 11 months ago by cypherpunks

You need to lock "Send websites a “Do Not Track” signal that you don’t want to be tracked" option to "Always".

Maybe just a typo from your part but TB devs have been (rightly) always opposed to enabling meaningless wastes of bytes such as DNT.

comment:2 Changed 11 months ago by cypherpunks

TB devs have been (rightly) always opposed to enabling meaningless wastes of bytes such as DNT.

But DNT is already enabled in Tor Browser 7.x.
Are you saying DNT will be turned off(like default Mozilla Firefox) in the next version?

comment:3 Changed 11 months ago by cypherpunks

related(but this ticket is old): https://trac.torproject.org/projects/tor/ticket/7921

comment:4 Changed 11 months ago by gk

Resolution: wontfix
Status: newclosed

Tor Browser 7.x does not have DNT enabled and we don't want that for a number of reasons, as we prefer a privacy by design approach which enforces anti-tracking protections instead of begging website owners to respect user preferences.

comment:5 in reply to:  3 Changed 11 months ago by cypherpunks

Replying to cypherpunks:

related(but this ticket is old): https://trac.torproject.org/projects/tor/ticket/7921

We miss badly those Mike Perry rants.

Note: See TracTickets for help on using tickets.