#26501 closed defect (duplicate)

All WebExtensions' toolbar icons missing on first launch

Reported by: rustybird Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: rustybird@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When I first launch a fresh Tor Browser on linux64, all the included WebExtensions' toolbar icons (i.e. HTTPSE and NoScript for esr60 / only HTTPSE for esr52) are missing. They're available in the toolbar customization dialog, but they're not automatically shown in the toolbar. The TorButton icon is present, maybe because it's a legacy extension?

Subsequent TB launches show all icons.

Child Tickets

Change History (7)

comment:1 Changed 16 months ago by rustybird

Cc: rustybird@… added

comment:2 Changed 16 months ago by cypherpunks

Subsequent TB launches show all icons.

That's the bug. See gk's redesign proposal for details.

comment:3 Changed 16 months ago by rustybird

Subsequent TB launches show all icons.

That's the bug. See gk's redesign proposal for details.

Nah, the HTTPS/NoScript buttons aren't even in a hamburger/overflow menu on first launch (contrary to gk's proposal). They're completely hidden until you reconfigure the toolbar, or restart the browser.

comment:4 in reply to:  3 Changed 16 months ago by cypherpunks

Replying to rustybird:

Nah, the HTTPS/NoScript buttons aren't even in a hamburger/overflow menu on first launch (contrary to gk's proposal).

gk's proposal was done with ff52-esr in mind, incorporating the extensions into the hamburger menu is no longer possible. So it's safe to assume that the only possibility then is that they shouldn't be shown (gk gave his - right I think - reasons for why that ought to be the case).

comment:5 Changed 16 months ago by rustybird

incorporating the extensions into the hamburger menu is no longer possible. So it's safe to assume that the only possibility then is that they shouldn't be shown

esr60 has a new optional "overflow menu" (marked » instead of the hamburger menu's ) that can be enabled/populated in the toolbar customization dialog.

Edit: I see it's not new per se - but the new thing about the overflow menu on esr60 is that you can can explicitly put buttons into it, whereas on esr52 it was populated automatically on, well, overflow. :)

Last edited 16 months ago by rustybird (previous) (diff)

comment:6 Changed 16 months ago by cypherpunks

That's a nice thing from Mozilla but I think that would violate the proposal:

2.1.1 Removing HTTPS Everywhere and NoScript from the Toolbar

  I'd propose we remove both NoScript and HTTPS Everywhere from the
  toolbar and leave Torbutton on it for now:

Anyway gk please detail this aspect more to know your exact position post-ff60-esr :)

comment:7 Changed 16 months ago by gk

Resolution: duplicate
Status: newclosed

Duplicate of #23359.

Note: See TracTickets for help on using tickets.