Opened 9 months ago

Closed 9 months ago

#26507 closed defect (duplicate)

When I go from duckduckgo to Whoxix the certificate page shows the exact same certificate for both pages

Reported by: Dbryrtfbcbhgf Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: #26456 Points:
Reviewer: Sponsor:

Description

Torbrowser 8a9
When I go from duckduckgo to Whoxix the certificate page shows the exact same certificate for both pages

  1. search duckduckgo for "dns" and check the certificate

then in the URL bar enter
http://dds6qkxpwdeubwucdiaord2xgbbeyds25rbsgr73tbfpqpt4a6vjwsyd.onion/
and click "Return". check the certificate
I made a video showing the bug occur.
Certificate Sha256 for duckduckgo
02:85:E5:3A:32:DE:65:3E:62:24:D0:13:B6:1A:C2:A2:A7:5D:62:D0:CE:7C:8A:0F:96:54:C7:29:77:37:1F:33
Certificate Sha256 for Whonix
02:85:E5:3A:32:DE:65:3E:62:24:D0:13:B6:1A:C2:A2:A7:5D:62:D0:CE:7C:8A:0F:96:54:C7:29:77:37:1F:33

Child Tickets

Change History (3)

comment:1 Changed 9 months ago by Dbryrtfbcbhgf

Video showing the bug.
https://filenurse.com/download/b692046fff43758923cb3305b6730990.html

Checking the Whonix certificate shows that it is a duckduckgo certificate, shown below.

https://s22.postimg.cc/du31ylv9d/bug.png

Last edited 9 months ago by Dbryrtfbcbhgf (previous) (diff)

comment:2 Changed 9 months ago by Dbryrtfbcbhgf

After closing Torbrowser and deleting the TorBrowser-Data folder, the bug still occurs every time.

comment:3 Changed 9 months ago by teor

Parent ID: #26456
Resolution: duplicate
Status: newclosed

Looks like a duplicate of #26456

Note: See TracTickets for help on using tickets.