#26525 closed defect (fixed)

Rename sandbox_getaddrinfo() functions.

Reported by: nickm Owned by: rl1987
Priority: Medium Milestone: Tor: 0.3.5.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: refactoring 035-roadmap-subtask
Cc: Actual Points:
Parent ID: #26481 Points:
Reviewer: dgoulet Sponsor:


From my branch for #26524:

+// XXXX rename these.  They are named as though they were sandbox-only,
+// XXXX but in fact they're the only allowed entry point to getaddrinfo.
+// XXXX They don't invoke the sandbox code; they only have an internal cache.

These functions should be called something like tor_getaddrinfo...(), or tor_getaddrinfo_cache...()

Child Tickets

Change History (5)

comment:1 Changed 11 months ago by rl1987

Owner: set to rl1987
Status: newaccepted

comment:2 Changed 11 months ago by rl1987

Status: acceptedneeds_review

comment:3 Changed 11 months ago by dgoulet

Cc: dgoulet removed
Keywords: refactoring added
Reviewer: dgoulet
Status: needs_reviewmerge_ready


comment:4 Changed 11 months ago by nickm

Keywords: 035-roadmap-subtask added

comment:5 Changed 11 months ago by nickm

Resolution: fixed
Status: merge_readyclosed


Note: See TracTickets for help on using tickets.