Opened 5 months ago

Closed 3 months ago

#26544 closed defect (fixed)

Images are not centered anymore in Tor Browser

Reported by: gk Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: ff60-esr
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

https://blog.torproject.org/new-release-tor-browser-80a9#comment-275908 noted that images loaded in Tor Browser based on ESR 60 are not centered anymore (example link: https://blog.torproject.org/sites/default/files/styles/full_width/public/image/tor-browser_0_3.png?itok=J0gWJiMB). This does not happen in a clean Firefox 60.0.2.

Child Tickets

TicketStatusOwnerSummaryComponent
#26189closedtbb-teamRemove our content policy hack for #8725Applications/Tor Browser

Change History (3)

comment:1 Changed 3 months ago by arthuredelstein

I confirmed this is caused by content-policy.js (from our #8725 patch) overzealously blocking the following two CSS files:

  • resource://content-accessible/ImageDocument.css
  • resource://content-accessible/TopLevelImageDocument.css

In principle, content-policy.js is now obsolete because https://bugzil.la/863246 was fixed (see #26189). An alternative/stopgap is to add whitelisting to these URLs.

comment:2 Changed 3 months ago by gk

I think we should just fix #26189 and don't do another round of stopgaps here.

comment:3 Changed 3 months ago by gk

Resolution: fixed
Status: newclosed

We are done here.

Note: See TracTickets for help on using tickets.