Opened 9 months ago

Closed 9 months ago

#26564 closed defect (fixed)

Tor compilation fails when cross-compiling for macOS

Reported by: gk Owned by:
Priority: Medium Milestone: Tor: 0.3.5.x-final
Component: Core Tor/Tor Version: Tor: unspecified
Severity: Normal Keywords: regression, macos, refactor
Cc: boklm, catalyst Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Our latest nightly build is failing when (cross)-compiling tor for macOS:

  CC       src/lib/process/env.o
src/lib/process/env.c:40:11: warning: implicit declaration of function '_NSGetEnviron' is invalid in C99 [-Wimplicit-function-declaration]
  return *_NSGetEnviron();
          ^
src/lib/process/env.c:40:10: error: indirection requires pointer operand ('int' invalid)
  return *_NSGetEnviron();
         ^~~~~~~~~~~~~~~~
1 warning and 1 error generated.
Makefile:7498: recipe for target 'src/lib/process/env.o' failed

Child Tickets

Change History (3)

comment:1 Changed 9 months ago by teor

Keywords: regression macos refactor added
Milestone: Tor: 0.3.5.x-final
Version: Tor: unspecified

Looks like we left out one of the headers in the refactor.

If we activate the macOS builders in Travis (#24629) we will catch issues like this earlier.

comment:2 Changed 9 months ago by teor

Cc: catalyst added
Status: newneeds_review

nickm just merged catalyst's fix-macos-includes to master, does master work for you now?

comment:3 Changed 9 months ago by gk

Resolution: fixed
Status: needs_reviewclosed

Yes, thanks.

Note: See TracTickets for help on using tickets.