Opened 9 years ago

Closed 8 years ago

#2657 closed defect (not a bug)

Two Questions I have about Tor usage

Reported by: zdtb Owned by:
Priority: Medium Milestone:
Component: - Select a component Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

First off does tor ever keep IP logs or other data of what users do over tor? Ive heard rumors that the some servers keeps logs of what the servers do for 24 hours in RAM memory (which is volatile when the server is restarted). Is this true? what happens when law enforcement agencies demand to see the server logs-do the server admins hand it over?

Secondly I am using the tor browser bundle for linux. Is there any way I can configure the Namoroka browser to use a proxy over tor?-that is I want the connection to look like 'tor node 1- tor node 2- tor node 3- proxy in browser settings'

Child Tickets

Change History (3)

comment:1 in reply to:  description Changed 9 years ago by zdtb

Replying to zdtb:

First off does tor ever keep IP logs or other data of what users do over tor? Ive heard rumors that the some servers keeps logs of what the servers do for 24 hours in RAM memory (which is volatile when the server is restarted). Is this true? what happens when law enforcement agencies demand to see the server logs-do the server admins hand it over?

Secondly I am using the tor browser bundle for linux. Is there any way I can configure the Namoroka browser to use a proxy over tor?-that is I want the connection to look like 'tor node 1- tor node 2- tor node 3- proxy in browser settings'

Just wondering do any of the live cd distributors such as tails support ethernet connections for new-ish routers? I tried the latest version of tails and it loaded up fine but when i connected my laptop via ethernet to the router i could get access to my ISP connection. It normally works all the time on ubuntu 10.10. Is it because tails is based on a much older version of ubuntu?

comment:2 Changed 9 years ago by zdtb

wont anyone answer my questions please?

comment:3 Changed 8 years ago by arma

Resolution: not a bug
Status: newclosed

Ah ha. I just found this trac ticket. You didn't give it a "component", so nobody noticed it.

In the future, you might like https://torproject.org/docs/faq#SupportMail

Putting random questions on trac is not the right way to get support.

That said, the very short answers are 1) No, correctly behaving Tor relays do not keep logs of what users do. There are a very few exceptions to this, where they collect statistics about general usage of their relay, but those statistics cannot be used to discover what a given user did. 2) Not easily. You might find some people on IRC who want to help you make it work.

Note: See TracTickets for help on using tickets.