Opened 9 months ago

Closed 6 months ago

#26581 closed enhancement (duplicate)

Import "Healthy Onions" to Tor Browser

Reported by: cypherpunks Owned by: tbb-team
Priority: Low Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by traumschule)

This ticket is related to #21952. For an introduction to onion services, see:
https://www.torproject.org/docs/onion-services.html.en
https://blog.torproject.org/cooking-onions-names-your-onions
https://blog.torproject.org/category/tags/onion-services
https://blog.torproject.org/category/tags/cooking-onions

https://addons.mozilla.org/en-US/firefox/addon/healthyonions/ (Mozilla deleted the plugin)

Tor Browser could ship this plugin being disabled per default.

Note: For the server side solution Alt-Svc see comment:31:ticket:21952 and #27502. Since #26365 Tor Browser understands this header.

Child Tickets

Attachments (1)

healthyonion-1.0.1810-an+fx.xpi (43.4 KB) - added by cypherpunks3 7 months ago.
Healthy.Onion

Download all attachments as: .zip

Change History (10)

comment:1 Changed 9 months ago by cypherpunks

I'm using this add-on for about 2 months. It's like "HTTPS Everywhere" but it can block dangerous onions.

+1 for adding this add-on to Tor Browser. Hope Tor devs do some code review.

comment:2 Changed 9 months ago by cypherpunks

Resolution: invalid
Status: newclosed

Who maintains the list? What if they're malicious? Even if the Tor Project maintains a list, are we to trust it? Block onions in an anti-censorship tool? How to deal with the media fallout when they were having bad press when they called out the racist Andre "I'm not going to court" Anglin stupid website (most people/bots have alt-right/racist tendencies online)? ...etc etc I can list 101 reasons if I didn't have time left.

comment:3 Changed 9 months ago by cypherpunks

Resolution: invalid
Status: closedreopened

I can list 101 reasons

Where?

comment:4 Changed 9 months ago by cypherpunks

Resolution: invalid
Status: reopenedclosed

Can you address the five reasons I mentioned before asking for more?

comment:5 Changed 7 months ago by traumschule

Giving users the option to activate this in preferences could be useful.

Changed 7 months ago by cypherpunks3

Healthy.Onion

comment:6 Changed 7 months ago by traumschule

i don't know what but something is with that xpi. clicking the link it is is not offered for installation but to download it. compare it with the one in #27323

comment:7 Changed 6 months ago by traumschule

Description: modified (diff)
Priority: MediumLow
Resolution: invalid
Status: closedreopened
Type: defectenhancement

I reopen this because it seems better aligned than #27513, not expecting it to be solved anytime soon. Please do not close, the discussion is not over. Above questions are valid but invalid seems wrong.

comment:8 Changed 6 months ago by traumschule

Description: modified (diff)

(clearnet links are more widely adopted)

comment:9 Changed 6 months ago by gk

Resolution: duplicate
Status: reopenedclosed

Duplicate of #19812.

Note: See TracTickets for help on using tickets.