#26651 closed defect (wontfix)

Calling event_enable_debug_mode() a second time exits the process

Reported by: tla Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Normal Keywords:
Cc: nickm Actual Points:
Parent ID: #25510 Points:
Reviewer: Sponsor:

Description

We could work around this (only enabled in debugging anyway), but it would be way nicer for us, if Tor just accepts this call multiple times.

Thanks! :-)

Child Tickets

Change History (5)

comment:1 Changed 15 months ago by dgoulet

Keywords: roadmap 035-roadmap-master 034-triage-20180328 034-included-20180328 removed
Status: newneeds_information

Can you enlighten me on what/where is that function event_enable_debug_mode()? I can't find it in the tor code?

comment:2 Changed 15 months ago by tla

*cough*, *cough*, uuuups...

Sorry, it seems, that's in libevent's event.h. We're currently using Libevent 2.1.8-stable.

Any recommendations how to handle this? If not, please just close it and sorry for the inconvenience.

comment:3 Changed 15 months ago by dgoulet

Cc: nickm added

It could be a specific libevent issue I'm guessing where they allow it to be called multiple time *or* make Tor call it only once during execution? ...

I'll let nickm comment on this.

comment:4 Changed 15 months ago by dgoulet

Milestone: Tor: 0.3.5.x-finalTor: unspecified

comment:5 Changed 14 months ago by nickm

Resolution: wontfix
Status: needs_informationclosed

Sorry, I think you'll need to talk to the libevent maintainers about this one. I don't maintain libevent any more.

Note: See TracTickets for help on using tickets.