Opened 5 months ago

Closed 5 months ago

Last modified 12 days ago

#26692 closed defect (not a bug)

sbws must not overwrite the bandwidth file, to avoid race conditions

Reported by: teor Owned by:
Priority: Medium Milestone: sbws: 1.0.x-final
Component: Core Tor/sbws Version:
Severity: Normal Keywords: sbws-1.0-must-closed-moved-20181128
Cc: pastly@…, juga@…, teor Actual Points:
Parent ID: #25925 Points:
Reviewer: Sponsor:

Description

Instead, it must write a temporary file, and then rename the temporary file to the bandwidth file name.

It should be a quick fix.

For background, see:
https://github.com/torproject/torspec/pull/21#discussion_r200971436

Child Tickets

Change History (5)

comment:1 Changed 5 months ago by teor

Parent ID: #21377

comment:2 Changed 5 months ago by teor

Parent ID: #21377#25925

comment:3 Changed 5 months ago by teor

Resolution: not a bug
Status: newclosed

juga tells me that sbws never overwrites the bandwidth file. Instead, it links to the latest file.

comment:4 in reply to:  3 Changed 5 months ago by pastly

Replying to teor:

juga tells me that sbws never overwrites the bandwidth file. Instead, it links to the latest file.

And since they are ~1.5 MiB (for me) and I generate them hourly, the folder gets massive. I'm going to make a low-priority ticket for addressing this

comment:5 Changed 12 days ago by teor

Keywords: sbws-1.0-must-closed-moved-20181128 added
Milestone: sbws 1.0 (MVP must)sbws: 1.0.x-final

Move all closed sbws 1.0 must tickets to sbws 1.0.x-final

Note: See TracTickets for help on using tickets.