#26792 closed defect (duplicate)

tor-0.3.4.5-rc: fails to build when configured with `./configure --disable-unittests`

Reported by: blueness Owned by: rl1987
Priority: Medium Milestone: Tor: 0.3.4.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: 034-must regression
Cc: Actual Points:
Parent ID: #26789 Points:
Reviewer: Sponsor:

Description

When configuring tor-0.3.4.5-rc with --disable-unittests the build fails with


make all-am
make[1]: Entering directory '/var/tmp/portage/net-vpn/tor-0.3.4.5_rc/work/tor-0.3.4.5-rc'

CCLD src/test/test-bt-cl

src/test/src_test_test_bt_cl-test_bt_cl.o: In function `crash':
/var/tmp/portage/net-vpn/tor-0.3.4.5_rc/work/tor-0.3.4.5-rc/src/test/test_bt_cl.c:43: undefined reference to `tor_assertion_failed_'
src/test/src_test_test_bt_cl-test_bt_cl.o: In function `main':
/var/tmp/portage/net-vpn/tor-0.3.4.5_rc/work/tor-0.3.4.5-rc/src/test/test_bt_cl.c:107: undefined reference to `init_logging'
/var/tmp/portage/net-vpn/tor-0.3.4.5_rc/work/tor-0.3.4.5-rc/src/test/test_bt_cl.c:108: undefined reference to `set_log_severity_config'
/var/tmp/portage/net-vpn/tor-0.3.4.5_rc/work/tor-0.3.4.5-rc/src/test/test_bt_cl.c:109: undefined reference to `add_stream_log'
/var/tmp/portage/net-vpn/tor-0.3.4.5_rc/work/tor-0.3.4.5-rc/src/test/test_bt_cl.c:110: undefined reference to `tor_log_update_sigsafe_err_fds'
/var/tmp/portage/net-vpn/tor-0.3.4.5_rc/work/tor-0.3.4.5-rc/src/test/test_bt_cl.c:112: undefined reference to `configure_backtrace_handler'
/var/tmp/portage/net-vpn/tor-0.3.4.5_rc/work/tor-0.3.4.5-rc/src/test/test_bt_cl.c:116: undefined reference to `clean_up_backtrace_handler'
/var/tmp/portage/net-vpn/tor-0.3.4.5_rc/work/tor-0.3.4.5-rc/src/test/test_bt_cl.c:117: undefined reference to `logs_free_all'
collect2: error: ld returned 1 exit status
make[1]: * [Makefile:5219: src/test/test-bt-cl] Error 1
make[1]: Leaving directory '/var/tmp/portage/net-vpn/tor-0.3.4.5_rc/work/tor-0.3.4.5-rc'
make:
* [Makefile:3468: all] Error 2

This regression was introduced after 0.3.4.2_alpha.

Child Tickets

Change History (6)

comment:1 Changed 15 months ago by nickm

Component: - Select a componentCore Tor/Tor
Keywords: 034-must regression added
Milestone: Tor: 0.3.4.x-final

comment:2 Changed 15 months ago by toralf

commit b7fae0f48 was bisected to be the first bad commit between 0.3.4.2-alpha and 0.3.4.3-alpha which caused this issue.

comment:3 Changed 15 months ago by nickm

Possible duplicate of #26789?

comment:4 Changed 15 months ago by blueness

Sorry, I must have missed #26789. It does indeed look like a duplicate.

comment:5 Changed 15 months ago by rl1987

Owner: set to rl1987
Status: newaccepted

comment:6 Changed 15 months ago by teor

Parent ID: #26789
Resolution: duplicate
Status: acceptedclosed

Duplicate of #26789

Note: See TracTickets for help on using tickets.