Opened 2 months ago

Closed 2 months ago

#26830 closed defect (fixed)

SKIP test_keygen.sh on Windows

Reported by: teor Owned by: teor
Priority: Medium Milestone: Tor: 0.3.5.x-final
Component: Core Tor/Tor Version: Tor: 0.2.7.3-rc
Severity: Normal Keywords: tor-ci, tor-testing, 035-must, regression, fast-fix
Cc: catalyst, saper@… Actual Points:
Parent ID: #26076 Points:
Reviewer: nickm Sponsor:

Description

We need our CI to be reliable, so we know if recent commits have broken the build.

So until we fix the root cause in #26076, let's SKIP test_keygen.sh on Windows.

Child Tickets

Change History (8)

comment:1 Changed 2 months ago by teor

Version: Tor: 0.2.7.3-rc

comment:2 Changed 2 months ago by teor

Reviewer: nickm
Status: assignedneeds_review

Please see my branch bug26830_029, particularly the appveyor CI.
(I don't have a Windows box to test it on.)

The Windows uname check is based on:
https://stackoverflow.com/questions/3466166/how-to-check-if-running-in-cygwin-mac-or-linux

I'm assigning nickm as reviewer, because he's on CI this week.

comment:3 Changed 2 months ago by teor

CI says:

test_keygen.sh runs and passes on Linux:
https://travis-ci.org/teor2345/tor/jobs/404690439

But apparently my uname test was wrong:

PASS: src/test/test_keygen.sh

https://ci.appveyor.com/project/torproject/tor/build/1.0.404

comment:4 Changed 2 months ago by teor

Status: needs_reviewneeds_revision

comment:5 Changed 2 months ago by teor

Status: needs_revisionneeds_review

Ok, turns out that we need to check for MSYS as well as CYGWIN and MINGW.

comment:6 Changed 2 months ago by teor

The test runs and passes on Linux:
https://travis-ci.org/teor2345/tor/builds/404717669

But is skipped on Windows:
https://ci.appveyor.com/project/torproject/tor/build/1.0.406

So as far as CI is concerned, we're good here.

comment:7 Changed 2 months ago by nickm

Squashed and merged to 0.2.9 and forward.

comment:8 Changed 2 months ago by nickm

Resolution: fixed
Status: needs_reviewclosed
Note: See TracTickets for help on using tickets.