Opened 2 months ago

Closed 2 months ago

#26853 closed defect (fixed)

SKIP test_key_expiration.sh on Windows

Reported by: teor Owned by: teor
Priority: Medium Milestone: Tor: 0.3.5.x-final
Component: Core Tor/Tor Version: Tor: 0.3.2.1-alpha
Severity: Normal Keywords: regression, fast-fix, tor-ci, tor-testing, 034-roadmap-subtask, 034-triage-20180328, 034-included-20180328, 034-deferred-20180602, 035-removed-20180711
Cc: catalyst, saper@… Actual Points:
Parent ID: #26076 Points:
Reviewer: nickm Sponsor:

Description

It looks like #26076 also affects test_key_expiration.sh.

So like #26830, let's SKIP test_key_expiration.sh on Windows until the underlying issue is fixed.

Child Tickets

Change History (5)

comment:1 Changed 2 months ago by teor

Reviewer: nickm
Status: assignedneeds_review
Version: Tor: 0.2.7.3-rcTor: 0.3.2.1-alpha

It turns out there is another flaky script on Windows.
The patch is just like #26830.

Please see my branch bug26853_032 on https://github.com/teor2345/tor.git

Assigning review to nickm because he's on CI this week.

comment:2 Changed 2 months ago by nickm

Sorry -- I don't see that branch on your github repo?

comment:3 Changed 2 months ago by teor

Oops, too many branches. It should be there now.

comment:4 Changed 2 months ago by teor

The Appveyor CI passed on this branch with SKIP:
https://ci.appveyor.com/project/teor2345/tor/build/1.0.6

The Travis CI passed on this branch with PASS:
https://travis-ci.org/teor2345/tor/builds/405593688

(Strictly, it was this branch merged to master, to get the Appveyor CI.)

comment:5 Changed 2 months ago by nickm

Resolution: fixed
Status: needs_reviewclosed

Merged to 0.3.2 and forward.

Note: See TracTickets for help on using tickets.