Opened 3 months ago

Closed 3 months ago

#26864 closed defect (not a bug)

did #18342 break RS' display of the host_name field?

Reported by: nusenu Owned by: metrics-team
Priority: Medium Milestone:
Component: Metrics/Relay Search Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

https://onionoo.torproject.org/details?limit=4&fields=host_name&fingerprint=4B5EEA88318698885B586286270449469949D514

{"version":"6.1",
"build_revision":"eee9cf8",
"relays_published":"2018-07-18 20:00:00",
"relays":[
{"host_name":"80.82.70.116"}
],
"bridges_published":"2018-07-18 19:51:43",
"bridges":[
]}

RS says:
Host Name:
None

Maybe it is just no longer aiming at displaying host_name field data but one of the new fields?

refs
#26834
#18342

btw:
does this make any sense:
"host_name":"89.245.126.97","verified_host_names":i59F57E61.versanet.de?

shouldn't host_name match the content of verified_host_names when that is present?

Child Tickets

Change History (2)

comment:1 Changed 3 months ago by irl

shouldn't host_name match the content of verified_host_names when that is present?

In theory, yes. host_name was meant to match one of the verified_host_names. It looks like they are not updated together for some reason.

It is not yet the case that all host names have been looked up with the new code and I had thought that this would be finished by now.

There is also an issue with some host names not being included in the indexes, although this could just be a delay between the details writer and the node indexer as they run separately.

comment:2 Changed 3 months ago by irl

Resolution: not a bug
Status: newclosed

Relay Search is correctly displaying what Onionoo has, there are still some issues in Onionoo though in #27050.

Note: See TracTickets for help on using tickets.