Opened 14 months ago

Closed 14 months ago

Last modified 14 months ago

#26887 closed defect (not a bug)

Unkillable tor.exe process in Windows 7 after starting Tor Browser

Reported by: jonny_11 Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: process, windows
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

After starting Tor Browser tor.exe process is launched. After closing Tor Browser tor.exe reside in memory, and it's unkillable. With regular methods (Task Manager) or with any other admin commands run from command line or PowerShell; or any third party tool like Process Hacker / Process Explorer. Only way to kill tor.exe is to reboot computer. The tor.exe process residing in memory preventing to start Tor Browser again.

Windows 7 64 bit
Tor Browser (firefox.exe) 52.9.0.6607 SHA-1: d6538c017b73f9745489ecb57c8f1958808b336a
Tor (tor.exe) no version in properties SHA-1: 1b26545eb73e5992ee64b77e1c5c98d1de495a34

Child Tickets

Change History (4)

comment:1 Changed 14 months ago by gk

Milestone: Tor: unspecified
Resolution: not a bug
Status: newclosed
Version: Tor: unspecified

Tor Browser as a normal, unprivileged user installed (which is the only way we recommend) does not have the privileges to resist killing by an admin account. Thus, this is not a Tor Browser bug. Maybe, if you have an antivirus/firewall tool running on your system that one responsible for this behavior?

comment:2 Changed 14 months ago by jonny_11

Only TorBrowser can start tor.exe process on my OS. After shutting down TB, tor.exe is not shutting down. It's still running independent (not as child process of TB) and keep occupying memory after TB is closed. TB and tor.exe are added to my firewall whitelist. AV is MS Security Essentials with TB directory added as excluded from interfering. How can I do some testst to identify the problem?

comment:3 in reply to:  2 Changed 14 months ago by gk

Replying to jonny_11:

Only TorBrowser can start tor.exe process on my OS. After shutting down TB, tor.exe is not shutting down. It's still running independent (not as child process of TB) and keep occupying memory after TB is closed. TB and tor.exe are added to my firewall whitelist. AV is MS Security Essentials with TB directory added as excluded from interfering. How can I do some testst to identify the problem?

Hard to say. You could try a clean Windows system and see if you can reproduce the problem. If not then narrowing down the cause by looking at the differences between your and the other system. Or you could try to solicit help from e.g. folks on the tor-talk mailing list (https://lists.torproject.org/cgi-bin/mailman/listinfo/tor-talk) or other support channels (https://www.torproject.org/about/contact.html.en). Good luck!

Note: See TracTickets for help on using tickets.