Opened 12 months ago

Closed 12 months ago

Last modified 12 months ago

#26899 closed defect (duplicate)

Rev counter prevents easy move of v3 onion service

Reported by: irl Owned by:
Priority: Medium Milestone: Tor: 0.3.5.x-final
Component: Core Tor/Tor Version: Tor: 0.3.2.1-alpha
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

This weekend I was moving a v3 onion service to another box. Copying the folder alone was not enough. I also had to manually edit the rev counter in the state file otherwise the hs descriptors were always rejected as invalid. It took me a while to figure this out, perhaps I was looking in the wrong place or perhaps this isn't documented.

Child Tickets

Change History (4)

comment:1 Changed 12 months ago by Dbryrtfbcbhgf

many changes have been made to the rev counter in the latest master, this ticket gives over the changes #25552. I wonder if your bug would still occur if you build the latest master from source and test it with this bug.

Here is the change log for the bug fixed in #25552

o Major feature (onion services):

  • Improve revision counter generation in next-gen onion services. Onion services can now scale by hosting multiple instances on different hosts without synchronization between them, which was previously impossible because descriptors would get rejected by HSDirs. Addresses ticket 25552.
Last edited 12 months ago by Dbryrtfbcbhgf (previous) (diff)

comment:2 Changed 12 months ago by irl

I was running Tor version 0.3.4.5-rc (git-f07dbed4810c96f1).. I don't know if this would have included that fix. It sounds like the description would fix it though.

comment:3 in reply to:  2 Changed 12 months ago by Dbryrtfbcbhgf

Replying to irl:

I was running Tor version 0.3.4.5-rc (git-f07dbed4810c96f1).. I don't know if this would have included that fix. It sounds like the description would fix it though.

It looks like the fix is only in 0.3.5.1-alpha-dev.

Last edited 12 months ago by Dbryrtfbcbhgf (previous) (diff)

comment:4 Changed 12 months ago by teor

Milestone: Tor: 0.3.5.x-final
Resolution: duplicate
Status: newclosed
Version: Tor: 0.3.2.1-alpha

This is a duplicate of #25552.

Please use the current git master, or Tor 0.3.5.1-alpha or later for the fix.
(It won't be backported, because it is a complex change.)

Note: See TracTickets for help on using tickets.