Opened 7 months ago

Closed 7 months ago

#26909 closed enhancement (not a bug)

ignore MyFamily lines and emit a warning on bridges

Reported by: nusenu Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

split from #26908:

tor in bridge mode should ignore MyFamily lines (meaning: not include that data when creating/uploading descriptors) in its torrc file and emit a warning.

Child Tickets

Change History (3)

comment:1 Changed 7 months ago by CristianCantoro

To be fair, this setting would still be useful. In my case (1) I am running a couple of middle relays and I would like to run a bridge, so in principle it could happen that a circuit goes through my bridge and the through one of my middle relays. Also in the same thread (1), I have been advised that I should not run an exit node if I am also running a bridge. Again, this is a case where setting MyFamily would be useful.

It would make sense if the bridge indicates all family members but the other non-bridge nodes do not contain the bridge fingerprint?

(1): https://lists.torproject.org/pipermail/tor-relays/2018-July/015735.html

comment:2 Changed 7 months ago by CristianCantoro

It looks like this functionality is alrady there

Jul 23 18:19:48.726 [warn] Listing a family for a bridge relay is not supported:
it can reveal bridge fingerprints to censors. You should also make sure you
aren't listing this bridge's fingerprint in any other MyFamily.

Running with Tor version 0.2.9.16 (git-9ef571339967c1e5).

Last edited 7 months ago by CristianCantoro (previous) (diff)

comment:3 Changed 7 months ago by teor

Resolution: not a bug
Status: newclosed
Note: See TracTickets for help on using tickets.