#26930 closed defect (not a bug)

Potential thundering herd HS upload once a day with hsv3

Reported by: asn Owned by:
Priority: High Milestone: Tor: 0.3.5.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: tor-hs hsv3 thundering-herd performance network-health
Cc: dgoulet Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Here is a potential bug we found with dgoulet at HOPE.

In set_rotation_time() we set the rotation time of the next descriptor to the next midnight UTC with no randomization at all:

  service->state.next_rotation_time =
    sr_state_get_start_time_of_current_protocol_run() +
    sr_state_get_protocol_run_duration();

After descriptors get rotated, a new descriptor is built and uploaded, so it might be the case that all hsv3s upload that new descriptor at the same time at midnight UTC.

We should investigate more.

Child Tickets

Change History (2)

comment:1 Changed 17 months ago by asn

Status: newneeds_information

Actually not sure if that's true because should_rotate_descriptors() uses the consensus valid-after, which means that it's not a thundering herd since it depends on what time the HS fetches the right consensus.

Not closing this so that we make sure this is right.

comment:2 Changed 16 months ago by dgoulet

Resolution: not a bug
Status: needs_informationclosed

I concur with asn here. Because a tor client downloads the consensus at a "random time" (within a timeframe), we end up with a bit of random when uploading the descriptors.

Note: See TracTickets for help on using tickets.