Opened 15 months ago

Closed 15 months ago

Last modified 15 months ago

#26951 closed defect (fixed)

Linux tbb execdesktop argument passing is broken

Reported by: benburrill Owned by: tbb-team
Priority: Low Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-rbm, TorBrowserTeam201807R
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Arguments with spaces get flattened due to the eval, so running

./start-tor-browser.desktop --search "hello world"

is effectively converted to

./start-tor-browser.desktop --search hello world

opening up two windows, one search for "hello" and one trying to connect to http://world

I have a patch, which I will try to attach.

Child Tickets

Attachments (1)

0001-Fix-execdesktop-argument-passing.patch (874 bytes) - added by benburrill 15 months ago.
Fixes the bug

Download all attachments as: .zip

Change History (7)

Changed 15 months ago by benburrill

Fixes the bug

comment:1 Changed 15 months ago by benburrill

Just to clarify, the patch is a git format-patch patch for the builders/tor-browser-bundle repo.

comment:2 Changed 15 months ago by gk

Keywords: tbb-rbm TorBrowserTeam201807R added

comment:3 Changed 15 months ago by gk

Thanks for the patch, testing it on the command line works for me. Did you test it with a GUI, like having Tor Browser registered in a way that its icon shows up in the launcher? Or while clicking on the icon in a file manager? I fear we are breaking something in those cases... More testing is needed I guess.

comment:4 Changed 15 months ago by gk

Status: newneeds_review

comment:5 Changed 15 months ago by benburrill

Yes, I can confirm that clicking the icon in a file manager and in the Xfce whisker menu works -- execdesktop isn't even involved in that case, so there would be no reason why it wouldn't.

Also, I realized after I posted this that it is a duplicate of #18022 (I tried searching earlier but somehow missed it then)

comment:6 Changed 15 months ago by gk

Resolution: fixed
Status: needs_reviewclosed

No worries. Let's test this in the next alpha. I pushed your patch to master (tor-browser-build) as commit 09111c4e8df1272dcbcf02f5c823e139801c44c4.

Last edited 15 months ago by gk (previous) (diff)
Note: See TracTickets for help on using tickets.