#26976 closed defect (not a bug)

Hardening Wrapper Removed in Debian Stretch

Reported by: sisbell Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: #26693 Points:
Reviewer: Sponsor:

Description

In the tor-browser-build project, the hardening wrapper is used in building binutils and gcc. This wrapper library has been deprecated and removed in debian stretch (which is used for cross compiling Android).

The recommended way of handling this is at: https://wiki.debian.org/Hardening

I've currently disabled hardening for Android builds until we put a fix in.

Child Tickets

Change History (5)

comment:1 Changed 16 months ago by boklm

Parent ID: #25164#26693

comment:2 Changed 13 months ago by boklm

It seems we don't need to build gcc. Do we still need to build binutils for the android build? If not, we can then close this ticket.

comment:3 Changed 13 months ago by boklm

Status: newneeds_information

comment:4 Changed 13 months ago by sisbell

I've confirmed that we don't need binutils for android build. I'm unable to modify or close this ticket (perhaps I don't have permissions to do so?).

comment:5 Changed 13 months ago by boklm

Resolution: not a bug
Status: needs_informationclosed
Note: See TracTickets for help on using tickets.