#26986 closed defect (fixed)

Appveyor CI fails on master due to #19506

Reported by: teor Owned by: teor
Priority: Medium Milestone: Tor: 0.3.5.x-final
Component: Core Tor/Tor Version: Tor: unspecified
Severity: Normal Keywords: fast-fix, tor-ci, regression, 035-must
Cc: Actual Points:
Parent ID: Points:
Reviewer: ahf Sponsor:

Description

For some reason, Appveyor CI didn't run on the pull request for #19506:
https://github.com/torproject/tor/pull/216

When #19506 was merged to master, it failed Appveyor with:

../src/tools/tor-print-ed-signing-cert.c:52:67: error: unknown conversion type character 'z' in format [-Werror=format=]
     fprintf(stderr, "ed25519_cert_parse failed with return value %zd\n",
                                                                   ^
../src/tools/tor-print-ed-signing-cert.c:52:21: error: too many arguments for format [-Werror=format-extra-args]
     fprintf(stderr, "ed25519_cert_parse failed with return value %zd\n",
                     ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
../src/tools/tor-print-ed-signing-cert.c:52:67: error: unknown conversion type character 'z' in format [-Werror=format=]
     fprintf(stderr, "ed25519_cert_parse failed with return value %zd\n",
                                                                   ^
../src/tools/tor-print-ed-signing-cert.c:52:21: error: too many arguments for format [-Werror=format-extra-args]
     fprintf(stderr, "ed25519_cert_parse failed with return value %zd\n",
                     ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Child Tickets

Change History (3)

comment:1 Changed 12 months ago by teor

Reviewer: ahf
Status: assignedneeds_review

Please see my branch bug26986 on https://github.com/teor2345/tor.git

Assigning review to ahf because he is on CI this week.

comment:2 Changed 12 months ago by ahf

Status: needs_reviewmerge_ready

Looks good to me.

comment:3 Changed 12 months ago by nickm

Resolution: fixed
Status: merge_readyclosed

Merged it!

Note: See TracTickets for help on using tickets.