#27042 closed defect (fixed)

Relay Search should not claim recommended_version is false when onionoo makes no statement about it

Reported by: BHydden Owned by: irl
Priority: Medium Milestone:
Component: Metrics/Relay Search Version: Tor: 0.3.3.9
Severity: Normal Keywords: bridge flag
Cc: Actual Points:
Parent ID: 27064 Points:
Reviewer: Sponsor:

Description

This relay (all bridges) is running a Tor version that is not recommended by the directory authorities and may contain known issues.

https://www.reddit.com/r/TOR/comments/94qk88/my_relay_is_running_a_tor_version_that_is_not/

https://i.imgur.com/iQQXHGa.png

Child Tickets

Change History (8)

comment:1 Changed 12 months ago by nusenu

Component: Obfuscation/BridgeDBMetrics/Onionoo
Owner: changed from sysrqb to metrics-team
Priority: MediumHigh
Summary: All bridges now have Not Recommended flagregression in recommended_version field for bridges starting at bridges_published 2018-08-04 17:49:22

Thanks for reporting this.

The following table shows onionoo's bridges_published timestamp and the number of bridges which have recommended_version set to true:

+---------------------+----------+
| 2018-08-04 00:49:21 |      693 |
| 2018-08-04 01:49:21 |      694 |
| 2018-08-04 02:49:21 |      694 |
| 2018-08-04 03:49:21 |      694 |
| 2018-08-04 04:49:22 |      694 |
| 2018-08-04 05:49:22 |      694 |
| 2018-08-04 06:49:22 |      694 |
| 2018-08-04 07:49:22 |      693 |
| 2018-08-04 08:49:22 |      693 |
| 2018-08-04 09:49:22 |      693 |
| 2018-08-04 10:49:22 |      692 |
| 2018-08-04 11:49:22 |      692 |
| 2018-08-04 12:49:22 |      692 |
| 2018-08-04 13:49:22 |      692 |
| 2018-08-04 14:49:22 |      692 |
| 2018-08-04 15:49:22 |      693 |
| 2018-08-04 16:49:22 |      693 |
| 2018-08-04 17:49:22 |      434 |
| 2018-08-04 18:49:22 |       49 |
| 2018-08-04 19:49:22 |       46 |
| 2018-08-04 20:49:22 |       46 |
| 2018-08-04 21:49:22 |       46 |
+---------------------+----------+

The following table shows the number of bridges that did NOT have the recommended_version field included:

+---------------------+----------+
| 2018-08-04 17:49:22 |      261 |
| 2018-08-04 18:49:22 |      649 |
| 2018-08-04 19:49:22 |      651 |
| 2018-08-04 20:49:22 |      651 |
| 2018-08-04 21:49:22 |      651 |
+---------------------+----------+

comment:2 Changed 12 months ago by nusenu

filed a related ticket for RS here: #27043

if it turns out that onionoo is just not providing the info because of missing upstream / collector data, then this is probably not an onionoo problem and we can change the component to RS and close #27043 as a duplicate of this.

Last edited 12 months ago by nusenu (previous) (diff)

comment:3 Changed 12 months ago by nusenu

Component: Metrics/OnionooMetrics/Relay Search
Priority: HighMedium

onionoo is back to normal:
https://lists.torproject.org/pipermail/metrics-alerts/2018-August/000055.html

and so is the recommended_version field.

Changing the component to RS.

Last edited 12 months ago by nusenu (previous) (diff)

comment:4 Changed 12 months ago by nusenu

Summary: regression in recommended_version field for bridges starting at bridges_published 2018-08-04 17:49:22Relay Search should not claim recommended_version is false when onionoo makes no statement about it

comment:5 Changed 12 months ago by irl

Owner: changed from metrics-team to irl
Status: newaccepted

Will look tomorrow

comment:7 Changed 11 months ago by irl

Parent ID: 27064

comment:8 Changed 11 months ago by irl

Resolution: fixed
Status: merge_readyclosed

This has been merged.

Note: See TracTickets for help on using tickets.