#27056 closed defect (not a bug)

sigusr2 only increases log verbosity to info, not debug

Reported by: drjohnson1984 Owned by:
Priority: Low Milestone: Tor: 0.3.5.x-final
Component: Core Tor/Tor Version: Tor: 0.3.3.7
Severity: Normal Keywords: logging sigusr2 034-backport 033-backport regression
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

In version 0.3.3.7 on linux, when you hit the tor process with sigusr2, it should switch to debug-level logging. It goes to info-level verbosity, but not debug.

Child Tickets

Change History (5)

comment:1 Changed 10 months ago by nickm

Keywords: 034-backport 033-backport regression added
Milestone: Tor: 0.3.5.x-final

comment:2 Changed 10 months ago by nickm

Status: newneeds_information

I just tried to reproduce this, and it switched to debug-level logging for me, both on 0.3.3 and on master.

Can you give some more information about the setup that you have here, and some instructions for reproducing this issue?

comment:3 Changed 10 months ago by drjohnson1984

There isn't much to tell. I'm running a 0.3.3.7 tor relay. I also have the tor source. When it receives sigusr2, right after it changes the log-level settings in the signal handler, it calls log_debug saying it had switched to debug-level. I never see this message.

Let me go back and check a couple of things. Make sure the rsyslogd isn't somehow routing debug-level messages to someplace other than /var/log/messages. I will also start tor with debug-level logging to verify it is logging correctly. I will update once I have done these

comment:4 Changed 10 months ago by drjohnson1984

Sorry to waste your time. It was an rsyslogd issue. this works fine. close it

comment:5 Changed 10 months ago by nickm

Resolution: not a bug
Status: needs_informationclosed

Okay; thanks for checking! (And thanks for reporting in the first place when you thought you had a bug. I'd rather have false positives than unreported bugs.)

Note: See TracTickets for help on using tickets.