Opened 7 months ago

Closed 7 months ago

#27074 closed defect (duplicate)

Metrics does not render graphs

Reported by: cKKuzt3QCP7R4CuQ3ujP Owned by: metrics-team
Priority: Medium Milestone:
Component: Metrics/Website Version:
Severity: Normal Keywords: metrics graph
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The metrics page for any relay I've looked at shows "No Data Available" for both graphs for the last couple of weeks. Same behaviour for and time range on the graphs. It displayed correctly before. I've tried on chromium, firefox, and android firefox.

In the debug console, I see the follow javascript errors that look relevant:
graph.js?v29:41 Uncaught TypeError: history[period].first.split is not a function

at graph.js?v29:41
at Function._.each._.forEach (underscore-min.js?v29:153)
at parseWeightHistory (graph.js?v29:40)
at n.parse_weights_data (graph.js?v29:159)
at success (main.js?v29:199)
at Object.success (graph.js?v29:148)
at i (jquery-3.2.1.min.js?v29:2)
at Object.fireWith [as resolveWith] (jquery-3.2.1.min.js?v29:2)
at A (jquery-3.2.1.min.js?v29:4)
at XMLHttpRequest.<anonymous> (jquery-3.2.1.min.js?v29:4)

graph.js?v29:12 Uncaught TypeError: history[period].first.split is not a function

at graph.js?v29:12
at Function._.each._.forEach (underscore-min.js?v29:153)
at parseHistory (graph.js?v29:11)
at n.parse_bw_data (graph.js?v29:128)
at success (main.js?v29:183)
at Object.success (graph.js?v29:118)
at i (jquery-3.2.1.min.js?v29:2)
at Object.fireWith [as resolveWith] (jquery-3.2.1.min.js?v29:2)
at A (jquery-3.2.1.min.js?v29:4)
at XMLHttpRequest.<anonymous> (jquery-3.2.1.min.js?v29:4)

Child Tickets

Change History (4)

comment:1 Changed 7 months ago by karsten

Sounds like the bug we're currently fixing in #27039. Leaving this open for irl to confirm, though.

comment:2 Changed 7 months ago by nusenu

Resolution: duplicate
Status: newclosed

duplicate of #27039

comment:3 Changed 7 months ago by nusenu

Resolution: duplicate
Status: closedreopened

comment:4 Changed 7 months ago by irl

Resolution: duplicate
Status: reopenedclosed
Note: See TracTickets for help on using tickets.