Opened 8 days ago

Closed 5 days ago

#27101 closed defect (fixed)

Error building tor in tor browser nightly builds

Reported by: boklm Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: TorBrowserTeam201808R, tbb-rbm
Cc: chelseakomlo, sukhbir Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

We currently have an error when building tor for linux i686 and x86_64, using master commit.

The build fails with the following error:

  CC     src/feature/dirauth/src_core_libtor_app_testing_a-shared_random_state.o
( cd "/var/tmp/build/tor-df444e482bc0/src/rust" ; \
                CARGO_TARGET_DIR="/var/tmp/build/tor-df444e482bc0/src/rust/target" \
                CARGO_HOME="/var/tmp/build/tor-df444e482bc0/src/rust" \
                cargo build --release  \
                --frozen \
                --manifest-path "/var/tmp/build/tor-df444e482bc0/src/rust/tor_rust/Cargo.toml" )
cargo: /var/tmp/dist/tor/Tor/libssl.so.1.0.0: no version information available (required by cargo)
cargo: /var/tmp/dist/tor/Tor/libssl.so.1.0.0: no version information available (required by cargo)
cargo: /var/tmp/dist/tor/Tor/libcrypto.so.1.0.0: no version information available (required by cargo)
cargo: /var/tmp/dist/tor/Tor/libcrypto.so.1.0.0: no version information available (required by cargo)
cargo: /var/tmp/dist/tor/Tor/libcrypto.so.1.0.0: no version information available (required by cargo)
error: process didn't exit successfully: `rustc -vV` (exit code: 101)
--- stdout
rustc 1.26.1
binary: rustc
commit-hash: unknown
commit-date: unknown
host: x86_64-unknown-linux-gnu
release: 1.26.1

--- stderr
error: couldn't load codegen backend "/var/tmp/dist/rust/lib/rustlib/x86_64-unknown-linux-gnu/codegen-backends/librustc_trans-llvm.so": "/var/tmp/dist/rust/lib/rustlib/x86_64-unknown-linux-gnu/codegen-backends/librustc_trans-llvm.so: undefined symbol: _ZNKSt3_V214error_category10_M_messageB5cxx11Ei"


make[1]: *** [src/rust/target/release/libtor_rust.a] Error 101
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory `/var/tmp/build/tor-df444e482bc0'
make: *** [all] Error 2

We don't have this error on our Windows and macOS build, but it is probably because we only use rust for the Linux build for now.

I started seeing this error on August 8.

Child Tickets

Change History (7)

comment:1 Changed 8 days ago by boklm

Component: Core Tor/TorApplications/Tor Browser
Owner: set to tbb-team

When trying to build commit f90c0533777f2220cd6fb5ed07a5b63cd9c3e881, I am now getting the same error. However this commit was building fine before. So it seems this error might not be related to tor.git changes, but something else.

comment:2 Changed 6 days ago by chelseakomlo

Cc: chelseakomlo added

comment:3 Changed 5 days ago by gk

Cc: sukhbir added
Keywords: TorBrowserTeam201808 tbb-rbm added

That's caused by the fix for #25485.

comment:4 Changed 5 days ago by boklm

Keywords: TorBrowserTeam201808R added; TorBrowserTeam201808 removed
Status: newneeds_review

comment:5 Changed 5 days ago by gk

Keywords: TorBrowserTeam201808 added; TorBrowserTeam201808R removed
Status: needs_reviewneeds_revision

I don' think adding libstdc++ to LD_LIBRARY_PATH is needed to make RPATH unavailable as the comment suggests. What about leaving the line you changed alone and adding two new ones like

# Fancy comment that needs to get added here
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$distdir/Tor/libstdc++/

?

comment:6 Changed 5 days ago by boklm

Keywords: TorBrowserTeam201808R added; TorBrowserTeam201808 removed
Status: needs_revisionneeds_review

comment:7 Changed 5 days ago by gk

Resolution: fixed
Status: needs_reviewclosed

Looks good. Merged to master as commit 3ba2bd456ac69f81ffbf5f0baa403ad005aeff34.

Note: See TracTickets for help on using tickets.