#27150 closed defect (duplicate)

Sandbox 1 is not working ubuntu 18.04 but worked fine in 16.04

Reported by: peekaboo Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When Sandbox 1 is entered in the torrc Tor does not function properly and I see the following errors in bionic syslog:

Could not open "/var/lib/tor/cached-certs": Permission denied
Could not open "/var/lib/tor/cached-consensus": Permission denied
Could not open "/var/lib/tor/unverified-consensus": Permission denied
Could not open "/var/lib/tor/cached-microdesc-consensus": Permission denied
systemd[1]: Started Anonymizing overlay network for TCP.
Could not open "/var/lib/tor/unverified-microdesc-consensus": Permission denied
Could not open "/var/lib/tor/cached-microdescs" for mmap(): Permission denied
Could not open "/var/lib/tor/cached-microdescs.new": Permission denied
Could not open "/var/lib/tor/cached-descriptors" for mmap(): Permission denied
Could not open "/var/lib/tor/cached-extrainfo" for mmap(): Permission denied
Before Tor can create a control socket in "/var/run/tor/control", the directory "/var/run/tor" needs to exist, and to be accessible only by the user and group account that is running Tor. (On some Unix systems, anybody who can list a socket can connect to it, so Tor is being careful.)
(Sandbox) Caught a bad syscall attempt (syscall openat)

Tor seems to work fine without Sandbox 1

Child Tickets

Change History (2)

comment:1 Changed 12 months ago by nusenu

Component: - Select a componentCore Tor/Tor

this is likely a duplicate of #25440

comment:2 Changed 12 months ago by nickm

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.