#27188 closed defect (wontfix)

hsv3 unavailable after reconnecting: No more HSDir available to query.

Reported by: traumschule Owned by:
Priority: Medium Milestone: Tor: 0.3.5.x-final
Component: Core Tor/Tor Version: Tor: unspecified
Severity: Normal Keywords: tor-hs hsdir
Cc: dmr Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

(Tor 0.3.5.0 needs a trac version)

Just noticed that my v3 $onion got unavailable while the webserver is still functional.

$ torify w3m $onion
w3m: Can't load $onion
Aug 17 16:14:09 host Tor[950]: Closed 1 streams for service [scrubbed].onion for reason resolve failed. Fetch status: No more HSDir available to query.

$ tor --version
Tor version 0.3.5.0-alpha-dev

$ curl -s localhost|grep title
   <title>Tor Project | Privacy Online</title>

$ torsocks curl torproject.org
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>302 Found</title>

tor$ git blame src/feature/hs/hs_client.c
c232b6b59c src/or/hs_client.c         (David Goulet               2017-09-26 10:45:24 -0400   57)     return "No more HSDir available to query";

i can repeat above multiple times but it does not refetch directories. keeping the instance running to see if it comes online again after three hours (#26769).

Child Tickets

Change History (4)

comment:1 Changed 15 months ago by traumschule

Looking at connection_edge.c and hs_client.c: fetch_v3_desc the request is turned down

      case HS_CLIENT_FETCH_NO_HSDIRS:
      case HS_CLIENT_FETCH_NOT_ALLOWED:
        /* Can't proceed further and better close the SOCKS request. */

because hs_client_refetch_hsdesc fails. The connection is closed (fetch_status_should_close_socks) and the request purged (hs_client_refetch_hsdesc). (skipping speculations)

Found an interesting bit in the log:

Aug 17 02:26:19 host Tor[950]: Tor has successfully opened a circuit. Looks like client functionality is working.
Aug 17 02:26:19 host Tor[950]: Bootstrapped 100%: Done
Aug 17 03:03:24 host Tor[950]: Your Guard <redacted> is failing more circuits than usual. Most likely this means the Tor network is overloaded. Success counts are 143/243. Use counts a re 45/51. 240 circuits completed, 6 were unusable, 91 collapsed, and 84 timed out. For reference, your timeout cu toff is 60 seconds.
Aug 17 08:26:17 host Tor[950]: Heartbeat: Tor's uptime is 6:00 hours, with 10 circuits open. I've sent 6.93 MB and received 15.22 MB.

comment:2 Changed 15 months ago by traumschule

So far no news. I tried to reproduce it by unplugging the cable and was unable, it took 12 minutes until all onions were reachable again (first 7 minutes i saw a lot: {REND} remove_invalid_intro_points(): Attempting to retry on).
Probably the issue was between the local tor service and it's guard, I assume the guard was under special load when the bug happened as and I have no intentions to try to reproduce that. :)

comment:3 Changed 15 months ago by dmr

Cc: dmr added

comment:4 Changed 15 months ago by dgoulet

Resolution: wontfix
Status: newclosed

Yeah most likely your Guard is the issue making all HSDir and Intro attempt to fail... And in this case, not much we can do about it because Tor thinks that the Guard is still "usable" so it let the HS subsystem to build circuits leading to your SOCKS request failing and even stalling.

Note: See TracTickets for help on using tickets.