Opened 9 months ago

Closed 9 months ago

Last modified 9 months ago

#27212 closed defect (not a bug)

Why do bridges run the retry_dns callback?

Reported by: teor Owned by:
Priority: Medium Milestone: Tor: 0.3.4.x-final
Component: Core Tor/Tor Version: Tor: 0.3.4.1-alpha
Severity: Normal Keywords: 034-must
Cc: dgoulet Actual Points:
Parent ID: #25899 Points:
Reviewer: Sponsor:

Description

In a4fcdc5dec, the following roles seem inconsistent:

+  CALLBACK(retry_dns, PERIODIC_EVENT_ROLE_ROUTER),
+  CALLBACK(check_dns_honesty, PERIODIC_EVENT_ROLE_RELAY),

It's probably unrelated, but I don't think clients write stats:

+  CALLBACK(write_stats_file, PERIODIC_EVENT_ROLE_ALL),

(Do onion services write stats?)

From https://trac.torproject.org/projects/tor/ticket/27080#comment:4

Child Tickets

Change History (3)

comment:1 Changed 9 months ago by teor

Parent ID: #27080

The original ticket was #25762.

comment:2 Changed 9 months ago by teor

Resolution: not a bug
Status: newclosed

All servers retry_dns initialisation if it fails. That's ok.

I think we actually want all roles calling the stats callbacks, so if we change roles, old relay statistics are erased by the next callback.

comment:3 Changed 9 months ago by teor

Parent ID: #27080#25899
Note: See TracTickets for help on using tickets.