Opened 5 months ago

Closed 5 months ago

Last modified 5 months ago

#27237 closed defect (fixed)

When the network doesn't have any exits, use the mid weight as the exit weight

Reported by: teor Owned by: teor
Priority: Medium Milestone: Tor: 0.3.4.x-final
Component: Core Tor/Tor Version: Tor: 0.2.6.2-alpha
Severity: Normal Keywords: tor-bootstrap
Cc: dgoulet, intrigeri Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

If we're building onion service paths, all our circuit ends will be mids.

  /* if the consensus has no exits, treat the exit fraction as 100% */
  if (router_have_consensus_path() != CONSENSUS_PATH_EXIT) {
    f_exit = 1.0;
  }

Bug fix on 55ad54e0146 in 0.2.6.2-alpha.

Child Tickets

Change History (6)

comment:1 Changed 5 months ago by teor

Keywords: tor-bootstrap 034-backport-maybe added; 034-must 035-must regression tor-bridge 034-backport removed
Status: assignedneeds_review

I fixed this issue in bug27237 on https://github.com/teor2345/tor.git.
It doesn't solve #27080 by itself, but I think it's a good idea going forward.

I don't think it's worth backporting to 0.3.4, because it doesn't fix any urgent issues.

comment:2 Changed 5 months ago by nickm

Resolution: fixed
Status: needs_reviewclosed

merged; agreeing with no backport.

comment:3 Changed 5 months ago by teor

Keywords: 034-backport 034-must added; 034-backport-maybe removed
Milestone: Tor: 0.3.5.x-finalTor: 0.3.4.x-final
Parent ID: #27080
Resolution: fixed
Status: closedreopened

This patch is required for non-exit networks to bootstrap in chutney in 0.3.4.

Please see my branch bug27237-034, which resolves a minor conflict in a log message.

comment:4 Changed 5 months ago by teor

Status: reopenedneeds_review

comment:5 Changed 5 months ago by teor

Resolution: fixed
Status: needs_reviewclosed

Oh, this patch is not required. I had a stale tor binary in src/app/tor.

comment:6 Changed 5 months ago by teor

Keywords: 034-backport 034-must removed
Note: See TracTickets for help on using tickets.