Opened 2 months ago

Closed 5 weeks ago

Last modified 4 weeks ago

#27264 closed defect (fixed)

Bookmark items are not visible on the bookmarks toolbar

Reported by: gk Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-8.0-issues, tbb-regression, tbb-8.0.1-can, GeorgKoppen201809, TorBrowserTeam201809R, AffectsTails
Cc: goupille, intrigeri Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

A user reported on the blog that bookmark items are not visible on the bookmark toolbar when making it visible. This affects all platforms it seems and does not happen in Firefox 60.1.0esr. See: https://blog.torproject.org/comment/276473#comment-276473 for the report.

Child Tickets

Change History (8)

comment:1 Changed 2 months ago by mcs

I did a few experiments on macOS while waiting for a browser build to finish. Here is what I learned:

  • This problem does not seem to occur in 8.0a9.
  • In 8.0a10, disabling all extensions does not help.
  • In 8.0a10, the problem disappeared after I went to View|Toolbars|Customize... and clicked "Restore Defaults".

comment:2 Changed 6 weeks ago by gk

Keywords: tbb-8.0-issues tbb-regression added; ff60-esr removed

comment:3 Changed 6 weeks ago by gk

Keywords: tbb-8.0.1-can added

Marking for 8.0.1 can.

comment:4 Changed 5 weeks ago by gk

Keywords: GeorgKoppen201809 added

comment:5 Changed 5 weeks ago by gk

Keywords: TorBrowserTeam201809R added
Status: newneeds_review

bug_27264 (https://gitweb.torproject.org/user/gk/tor-browser.git/commit/?h=bug_27264&id=1d974fa2b70dfe07bea896c99c88d7f62f3268a5) in my public tor-browser repo has a fix for review. That might not solve the problem for users that are already on 8.0 because the original value of browser.uiCustomization.state gets saved in the profile dir in prefs.js as a user pref. On the other hand, the update happened "properly" for those that were on 7.5.6 before... Anyway, I think there is not much we can do than adding the missing \"personal-bookmarks\" item.

Last edited 4 weeks ago by gk (previous) (diff)

comment:6 in reply to:  5 Changed 5 weeks ago by arthuredelstein

Status: needs_reviewmerge_ready

Replying to gk:

bug_27264 (https://gitweb.torproject.org/user/gk/tor-browser.git/commit/?h=bug_27264&id=1d974fa2b70dfe07bea896c99c88d7f62f3268a5) in my public tor-browser repo has a fix for review.

Looks good to me.

comment:7 Changed 5 weeks ago by gk

Resolution: fixed
Status: merge_readyclosed

Thanks! Merged to tor-browser-60.2.0esr-8.5-1 (commit 1d974fa2b70dfe07bea896c99c88d7f62f3268a5) and cherry-picked to tor-browser-60.2.0esr-8.0-1 (commit 3444c43fc135f68a2da2ebcded8c0adb89254f3f).

comment:8 Changed 5 weeks ago by mcs

Cc: goupille intrigeri added
Keywords: AffectsTails added

#27767 is a duplicate.

Note: See TracTickets for help on using tickets.