#27287 closed enhancement (not a bug)

make distcheck should run make check

Reported by: teor Owned by: teor
Priority: Medium Milestone: Tor: 0.3.5.x-final
Component: Core Tor/Tor Version: Tor: 0.3.0.1-alpha
Severity: Normal Keywords: fast-fix
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

make distcheck is missing check-changes, and maybe other checks

Child Tickets

Change History (2)

comment:1 Changed 10 months ago by teor

Status: assignedneeds_review
Type: defectenhancement
Version: Tor: 0.3.0.1-alpha

make check runs check-local.
But it looks like make distcheck runs check without check-local.

It's not clear from the documentation if this is an intended behaviour:
https://www.gnu.org/software/automake/manual/automake.html#Extending
https://www.gnu.org/software/automake/manual/automake.html#Checking-the-Distribution

I think we can fix this issue by adding a distcheck-hook that runs check-local.

See my branch bug27287 on https://github.com/teor2345/tor.git for a fix.
CI is at:

I tested it by failing make check-spaces with and without the fix:

If the fix works, distcheck jobs in the build without the fix will succeed, but all jobs will fail in the build with the fix.

comment:2 Changed 10 months ago by teor

Resolution: not a bug
Status: needs_reviewclosed

There is no difference between make distcheck with and without the fix: they all fail due to make checks-spaces.

distcheck must have succeeded for some more complex reason, and I don't think it's worth tracking it down.

Note: See TracTickets for help on using tickets.